Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 04-11-2017, 08:10 PM #1
Opteron-O3
Elite Spyder Owner
 
Opteron-O3's Avatar
 
Join Date: Feb 2005
Location: Garland, Texas
Opteron-O3 is a Supporting Member
 has been a member for 10 years
Opteron-O3 supports Ninja Paintball
BT-4 Delta Firing Issues

I disassembled my BT4 Delta (mechanical) to clean it. But when I reassembled it, I now have firing issues. This isn't my first time doing maintenance. And the marker is maybe 2 months old and I have played twice with it.

I would cock the marker. Gas it up with a full tank. Fire and it would only go in "full auto mode". The sear seems to not catch. Or not enough air is cycling through.

I've torn it apart and put it back together. Re lubed and nothing. I haven't replaced o-rings because they are still in great condition (new). I'm looking for my spares as we speak.

I'm just puzzled. I would appreciate some help
Opteron-O3 is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 04-18-2017, 10:30 AM #2
mark1975
Hawkeye
 
mark1975's Avatar
 
Join Date: Sep 2005
Location: NJ
 has been a member for 10 years
mark1975 works for a Paintball manufacturer
I would check the back of the Powertube and make sure its not cracked or damaged.
mark1975 is offline   Reply With Quote
Old 04-18-2017, 03:35 PM #3
Opteron-O3
Elite Spyder Owner
 
Opteron-O3's Avatar
 
Join Date: Feb 2005
Location: Garland, Texas
Opteron-O3 is a Supporting Member
 has been a member for 10 years
Opteron-O3 supports Ninja Paintball
Quote:
Originally Posted by mark1975 View Post
I would check the back of the Powertube and make sure its not cracked or damaged.
Thanks for the reply. I did check that and nothing. However I got curious and switched back to the stock SS hose and ASA. It started working after that... So it seems as if the previous hose I had was pinched internally. Externally the hose looked fine, but when I looked down the hose it was pinched. So there you go lol. Thanks for your help though! I do appreciate it!
Opteron-O3 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump