Find fields & stores near you!
Find fields and stores
PbNation News
PbNation News
Community Focus
Community Focus

Thread Tools
Old 08-03-2015, 11:01 PM #1
Join Date: Aug 2015
Question Invert Mini board turns off when I fire it

I have an invert mini and I'm having some issues with it, wondering if anyone can help?
When I have the board disconnected from the gun I can turn it on and the blue light is solid.

Then when I connect it to the gun, the blue light starts flashing instead. When I pull the trigger, it shuts off and then there is a clicking noise
If I connect it to the gun, then turn it on while connected, it just flashes red and shuts off.

Any ideas for what is causing this?
Thanks in advance
thedoktor1266 is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Old 08-03-2015, 11:13 PM #2
Join Date: Aug 2014
Annual Supporting Member
C0lin owns a Planet Eclipse Etek
Try asking this question here: (in the mini section)

You may get a better response.

Good luck with your mini. I have one but honestly I don't know what could be causing this.
C0lin is offline   Reply With Quote
Old 08-04-2015, 08:41 PM #3
Always use Jakob's
safariguy5's Avatar
Join Date: Jul 2015
Location: Berkeley, CA
Annual Supporting Member
safariguy5 owns a Planet Eclipse Geo
safariguy5 plays in the APPA beginner division
safariguy5 has achieved Level 1 in PbNation Pursuit
safariguy5 has perfected Level 1 in PbNation Pursuit
safariguy5 supports Empire
The mini board has 8 pins to where you plug it into the main frame. Make sure all the pins are aligned and go in, sometimes, you get a mismatch and only half go in. You may need to change the screw tightness on the front grip to get it to align properly.
safariguy5 is offline   Reply With Quote

Thread Tools

Posting Rules
Forum Jump