DSR reg issues - PbNation
Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

 
Archived Thread - Cannot Edit  
Old 08-16-2007, 09:38 PM #1
Loganat0r
 
 
Loganat0r's Avatar
 
Join Date: Dec 2006
DSR reg issues

Just got my T-board installed yesterday and took it outside to test. Well the board works great but after gasing up the marker i'd get 2 or 3 shots and it wouldent re-cock. I tried it again after disconnecting the hpa tank and watched the pressure gauge start at around 350 psi and drop with each shot until, again, i wouldent re-cock. So is this the reg not recharging? i replaced the oring in the large lower screw that holds the reg to the fitting that connects to the hose. Is it the this oring or somthing else?
Loganat0r is offline  
Old Sponsored Links Remove Advertisement
Advertisement
Old 08-17-2007, 12:16 AM #2
ThatOneGuy?
 
 
ThatOneGuy?'s Avatar
 
Join Date: Aug 2007
try adjusting the pressure around until you find where it works
__________________
sig.
ThatOneGuy? is offline  
Old 08-17-2007, 01:43 AM #3
Loganat0r
 
 
Loganat0r's Avatar
 
Join Date: Dec 2006
the reg isnt recharging so i cant change the pressure. i get like 3 shots with descresing pressure and then nothing, only the noid clicks, air flow through the marker stops.
Loganat0r is offline  
Old 08-17-2007, 02:11 AM #4
fishballer06
ShockerRepair.com
 
fishballer06's Avatar
 
Join Date: Mar 2005
Location: PA
Annual Supporting Member
fishballer06 is BST Legit
fishballer06 plays in the PSP
fishballer06 donated to help Peyton Trent
fishballer06 supports our troops
fishballer06 supports DLX Technology
just don't keep the stock reg cuz it really does suck no matter what you do, I've had three piranha's and the stock reg sucked on them all, just replace it for $25-30, sorry

if you really wanted to fix it, I would just say raise the pressure some, my dsr's have always had a creeping problem, not a recharge problem, so good luck
fishballer06 is offline  
Old 08-18-2007, 01:05 AM #5
plushdragon
 
 
plushdragon's Avatar
 
Join Date: Sep 2003
 has been a member for 10 years
plushdragon helped look for balloons
Re:

you may have pinched an o-ring in the reg or there dirt on the reg seat causing the reg not to work right. if you have a small c02 tank a quick check is to remove the reg from the marker and screw a small c02 tank dir into the asa if the marker shoots fine then it a reg issue.
__________________
Does an ursine quadruped void wastes in an arboreal environment?
plushdragon is offline  
Old 08-18-2007, 08:04 PM #6
Loganat0r
 
 
Loganat0r's Avatar
 
Join Date: Dec 2006
Yeah i figured it out, one of the o-rings in the upper part of the reg had come unseated. strap wrench = win when taking the regulator apart. Anyways it works fine now, played last night and no problems so it's fixed. Thanks for the suggestions
Loganat0r is offline  
 




Posting Rules
Forum Jump