Armotech Pluto Help Needed - PbNation
Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

 
Archived Thread - Cannot Edit  
Old 03-05-2007, 12:52 AM #1
Nexus-SA
 
 
Join Date: Mar 2007
Armotech Pluto Help Needed

I am situated in South Africa. I have a Armotech pluto marker and are
experiencing some great difficulty with it.

When you clean the gun it fires fine, but when it is hot when you go play
paintball the gun can't even shoot 10 meters with out atleast a 50cm ball
drop (impossible to play)

Now I will explain were all started going wrong:

The moving parts was getting very dry, I wanted to lubricate it and were
asking arround what the best option will be for a paintball marker. So I was
recomended silycone grease. (A big no no)
The grease re-acts the white o-rings, they became yellow and then started to
break.

I striped the gun to the bone and washed it out with fuel to try and get the
sylicone out of system. I replaced all the o-rings in the marker. I had a
problem in the bottom chamber. There is a silver part with two blue o-rings
on. I think they call it a "turbo valve assembly". I could not find that
presis size o-ring so I replaced it with the white orings that the rest of
the parts is using.

Marker seemed to be fine, I then screw a CO2 cylinder in from another team
player and I felt the cylinder turned in very stiff. After that when my own
cylinder turn in stiff the marker shot so bad and it cuts the o-ring on my
co2 cylinder. I tried to see what was wrong with the tread and also tried to
clean the tread with not a lot of success. Unfortunly there is no armotech
dealers or anybody that keeps parts on it either to be able to replace the
bottom line adaptor.

Still I do not know what is causing the inconsistant drop in presure. I have
listern to here is there is any leaks when I am fireing shots, I have
replaced all the o-rings. I realy like the marker and woul like to get it
fixed. Do you have any advice what to do?
Nexus-SA is offline  
Old Sponsored Links Remove Advertisement
Advertisement
Old 03-05-2007, 02:46 PM #2
devilmountainsports
NightStalkers
 
devilmountainsports's Avatar
 
Join Date: Apr 2004
 has been a member for 10 years
Sounds like you have the bolt in upside down. If you your ASA adapter is cutting orings replace it with a new one. Any standard part will work.
__________________
Night Stalkers Scenario Paintball -Sponsored by Nobody
Please do not contact us for sponsorships we are not interested.

I no longer own DMSPaintball.com. Call the store directly at 925-608-3319 for all your questions.
devilmountainsports is offline  
 




Posting Rules
Forum Jump