Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

 
Archived Thread - Cannot Edit  
Old 06-27-2005, 03:13 PM #1
Toll
Custom user title
 
Join Date: Jun 2005
Location: Ontario, Canada
Unresponsive fire - Mongoose 2 lcd

Lately my friend complained of flat out "not firing" with his goose and now I have the same issue with mine. I pull it as fast as I can, but after the first shot, it no longer fire's...like full auto not working, multi-turbo..that stuff.

Is it the battery or something else that seems to be the issue? I can't walk it faster than 3 balls per second otherwise it just stops firing.
Toll is offline  
Old 06-27-2005, 03:15 PM #2
Lynxx
Hardcore 'Til I Die
 
Lynxx's Avatar
 
Join Date: Mar 2005
Location: Bella Vista, Arkansas
replace the battery..most likely your problem
__________________
Hardcore 'Til I Die
Lynxx is offline  
Old 06-27-2005, 04:54 PM #3
jjdustr340
My son will bunker you.
 
jjdustr340's Avatar
 
Join Date: Jan 2004
Location: Home of the Buckeyes!!
jjdustr340 is a Moderator
jjdustr340 is a Supporting Member
 has been a member for 10 years
jjdustr340 posts videos on PbNation
jjdustr340 supports our troops
jjdustr340 is one of the top 500 posters on PbNation
jjdustr340 is Legendary
Yep battery would be my guess as well. It sounds like the battery is so weak that it has enough juice to energize the capacitor for one shot, but then not enough to recharge it.
jjdustr340 is offline  
Old 06-28-2005, 04:04 PM #4
hotshot_1392
 
 
hotshot_1392's Avatar
 
Join Date: Jun 2005
Location: Iowa
If it isn't the battery it could be that the connections to the capacitor could be bad, like the sodier could have gone bad or came apart and you might have to resodier the wires, this happened on my Mongoose 1.
__________________
Olive 05 Proto Matrix
-Black 14" Dye Ultralight
Smoke Halo B
PMI 68/4500 Tank
hotshot_1392 is offline  
 




Posting Rules
Forum Jump