Find fields & stores near you!
Find fields and stores
PbNation News
PbNation News
Community Focus
Community Focus

Thread Tools
Old 04-24-2015, 05:27 PM #1
Ford's Avatar
Join Date: Nov 2001
Location: Austin 49
Ford is a founding member
 has been a member for 10 years
Palmer Stabilizer - stuck at 400ish PSI

I'm trying to figure out where to start with an issue I'm having with my old, trusty Palmer Stabilizer.

The problem: I hadn't touched this thing in many years. I recently gassed it up attached to a pressure gauge, and got a reading just over 400 psi. I gave a couple turns counter/clock wise and checked again... pressure is basically the same. NO matter the number of cranks, the read out stays at 400 psi +- 10 psi. What could be causing this?

To be clear, this is the product:

I've had this on a 96 cocker so it's pretty old. I can crack it open and the internals look pretty good. I've got one bad o-ring I need to replace, but I don't understand why I'm not getting any adjustment in pressure as I try to adjust the screw on the bottom.

Is there another piece that needs to be replaced? Ive tried two different gauges so I know it's not likely a broken gauge causing the reading.
"Originally posted by Bronk0
Everyone put something in your sig about it...

like PORN THREAD 10/24/04: I was there.
Ford is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Old 04-27-2015, 06:04 AM #2
Got_Paint's Avatar
Join Date: Dec 2003
Location: Sacramento,CA
 has been a member for 10 years
average age of buna orings before they turn to complete goo is about 8 years. If its been as long as you say I'd assume all of them could stand a rebuild.

I'd just do the rebuild and see if its still giving you the same issue. This forum is dead I'd ask in the PPS section of mcarterbrown if you want better answers from people more knowledgeable than I.
Got_Paint is offline   Reply With Quote

Thread Tools

Posting Rules
Forum Jump