Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 10-14-2013, 07:47 AM #1
Durk85
You can't be serious....
 
Durk85's Avatar
 
Join Date: Jan 2012
Location: NH
Durk85 owns a Planet Eclipse Geo
Durk85 owns a Planet Eclipse Ego
Durk85 supports Team VICIOUS
Double feeding

Finally got to take my SS out and it was shooting ok but it was getting in the habit of double,triple,quad feeding. I am going to assume it could be a few different things, first being the timing. It might be out of time. So that I can understand but are there other issues that I could be having?? No leaks and the board is a Zero B. Its set on semi. What other things can I look for???
__________________
Badges????? We don't need no stinkin badges!!!!
http://www.zdspb.com/index.html
http://www.icd-owners.com/html/index.php
Durk85 is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 10-14-2013, 09:34 AM #2
Angryface
 
 
Angryface's Avatar
 
Join Date: Jan 2013
Location: Wyoming, MI
Angryface has perfected Level 1 in PbNation Pursuit
I'm assuming you are using a modern hopper and not a revy, if your timing is off then your bolt will stay open longer than it should allowing the hopper to force extra balls into the barrel. Had a similar problem with a mech cocker and just needed to train myself to get of the trigger faster, but with electro you should just need to tweak a couple of settings I think.
Angryface is offline   Reply With Quote
Old 10-14-2013, 09:43 AM #3
Durk85
You can't be serious....
 
Durk85's Avatar
 
Join Date: Jan 2012
Location: NH
Durk85 owns a Planet Eclipse Geo
Durk85 owns a Planet Eclipse Ego
Durk85 supports Team VICIOUS
Im was using a Vlocity JR with Dynasty chip. There might be something going on with the eyes too. If the eyes are dead or dying, it might not be senoring the ball in the breach
__________________
Badges????? We don't need no stinkin badges!!!!
http://www.zdspb.com/index.html
http://www.icd-owners.com/html/index.php
Durk85 is offline   Reply With Quote
Old 10-14-2013, 10:54 AM #4
hmcl281
 
 
hmcl281's Avatar
 
Join Date: Dec 2003
 has been a member for 10 years
sound like the sear is not releasing each time or not fully cocking back each time. simple thing to try is a new battery.
__________________
hmcl281 is offline   Reply With Quote
Old 10-14-2013, 11:05 AM #5
Durk85
You can't be serious....
 
Durk85's Avatar
 
Join Date: Jan 2012
Location: NH
Durk85 owns a Planet Eclipse Geo
Durk85 owns a Planet Eclipse Ego
Durk85 supports Team VICIOUS
Yeah I'll try that. Hopefully I will be going again in a couple weeks and see if that helps it
__________________
Badges????? We don't need no stinkin badges!!!!
http://www.zdspb.com/index.html
http://www.icd-owners.com/html/index.php
Durk85 is offline   Reply With Quote
Old 06-22-2014, 03:04 PM #6
AcidRaindrops00
 
 
Join Date: Nov 2013
Sear Lug Problems

I am very familiar with this problem!

On me Free Flow Rhythm this starts to happen as the battery begins to drain.

My only question is the hammer firing in between these double, triple, quad feeds?

If not then you need screw out the sear lug. The issue in this situation is that the sear lug is hanging to low and the sear cant stay down or drop fast enough to clear the lug.

I would back it out until it no longer catches on your triggers sear, screw it back until it catches and air it up. Chances are that it will burp and not properly fire. If this happens so turn it a quarter turn till it doesnt sound/shoot hideous.

This step is optional: You can leave it there but I usually turn it back out an 8th of turn till it does it again and turn back in a 12th of a turn to find your sear lugs sweet spot ... That way you get the most efficiency out of your battery. Who knows maybe you find it on your first try!

Hope that helps!

-CC

Last edited by AcidRaindrops00 : 07-27-2014 at 03:32 PM. Reason: Horrible Grammer
AcidRaindrops00 is offline   Reply With Quote
Old 07-09-2014, 07:04 PM #7
ascent
 
 
ascent's Avatar
 
Join Date: Apr 2014
I'd check the ball detent. Shouldn't double feed if its working properly.
ascent is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump