Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 03-06-2014, 09:47 AM #1
Bobby87
 
 
Join Date: Mar 2014
Brand new etha will not fire.

Got a brand new Etha yesterday and as soon as I gassed it up it shot once and then gave me a flashing purple light and wouldn't' t fire again. I've put new Duracell batteries in it, cleaned any lube that could prevent bolt stick, and the gun came with the spring less poppet assembly already installed. I've got a tank with 3000psi on it, so I have plenty of air. I've also tried to fire it with the eyes off and got nothing. What could be the problem?
Bobby87 is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 03-06-2014, 11:01 PM #2
vandall1986
Do or do not
 
vandall1986's Avatar
 
Join Date: Dec 2013
Location: Redlands, Ca
vandall1986 is BST Trusted
vandall1986 owns a Planet Eclipse Lv1
vandall1986 has achieved Level 1 in PbNation Pursuit
vandall1986 has achieved Level 2 in PbNation Pursuit
vandall1986 has achieved Level 3 in PbNation Pursuit
Best thing you can do is read your manual. Somewhere in that magical book it covers the lights and what to do. I don't remember what page but it's in there.
__________________
There is no better than adversity. Every defeat, every heartbreak, every loss, contains its own seed, its own lesson on how to improve your performance next time.
vandall1986 is offline   Reply With Quote
Old 03-07-2014, 10:00 AM #3
Bobby87
 
 
Join Date: Mar 2014
Got it shooting good this mourning. Went through the manual and saw where it mentioned the trigger not being adjusted correctly could cause it not to fire. So I readjusted the trigger and cleaned up my reg. and the gun stated shooting great.
Bobby87 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump