Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 04-07-2013, 06:16 PM #1
PAC0
 
 
PAC0's Avatar
 
Join Date: Sep 2002
Location: 32 8' N 81 12' W
 has been a member for 10 years
Gen E with flashing LED?

Hey guys,
Got a gun today that has been in a closet for awhile. Guy knows nothing about it and wanted it fixed up.

Gen E trix, LED with Gun20 chip. Blind, was missing trigger pin and screws on the frame are stripped (haven't been able to remove the frame yet). Bolt is obviously going to need new rings and lube.

The big problem at the moment is when I turn it on, the LED blinks and will not cycle. I also can't turn it off unless I remove the battery. What does the flashing LED mean?!

Thanks for the help.
__________________
Sig goes here.
PAC0 is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 04-07-2013, 06:20 PM #2
BonesJackson
Legendary
 
BonesJackson's Avatar
 
Join Date: Mar 2009
Location: California
GUN20 LED has no settings where it flashes. Sounds sort of ****ed up to be honest.
BonesJackson is online now   Reply With Quote
Old 04-07-2013, 06:29 PM #3
PAC0
 
 
PAC0's Avatar
 
Join Date: Sep 2002
Location: 32 8' N 81 12' W
 has been a member for 10 years
Yeah, I'm a little worried that its some kind of board/wiring malfunction.

I actually got the thing to fire a couple times(somehow!) when he first brought it in and then the light started flashing.
__________________
Sig goes here.
PAC0 is offline   Reply With Quote
Old 04-08-2013, 06:53 PM #4
PAC0
 
 
PAC0's Avatar
 
Join Date: Sep 2002
Location: 32 8' N 81 12' W
 has been a member for 10 years
AHA moment.
The board was pushed too far forward and the trigger switch was pressed just slightly when powering on. This is the flashing green light. Explains why gun wouldn't cycle (without A LOT of trigger movement in the frame) and wouldn't power down.
Now, if I could just get the damn frame off.
__________________
Sig goes here.
PAC0 is offline   Reply With Quote
Old 04-08-2013, 08:13 PM #5
TaggRat
 
 
TaggRat's Avatar
 
Join Date: Nov 2005
Location: Angier, North Carolina
TaggRat owns a Planet Eclipse Geo
are the frame screws stripped?
__________________
My Marker Collection
TaggRat is offline   Reply With Quote
Old 04-10-2013, 12:15 AM #6
RAPER
Matrix Dr
 
RAPER's Avatar
 
Join Date: Sep 2003
Location: Illinois
Annual Supporting Member
 has been a member for 10 years
RAPER is playing at Living Legends VI
RAPER owns a Planet Eclipse Ego
RAPER owns a Planet Eclipse Lv1
RAPER plays in the APPA D5 division
you will just have to slot the screw heads with a dremel or something of the sort. get that beast up and running.. it deserves more than to be sitting in a closet, all forgotten.
RAPER is offline   Reply With Quote
Old 04-15-2013, 06:17 PM #7
PAC0
 
 
PAC0's Avatar
 
Join Date: Sep 2002
Location: 32 8' N 81 12' W
 has been a member for 10 years
Yep, got the screw out with the dremel and got it going. Now, just need to fix some serious shootdown and shes ready to roll I think.
__________________
Sig goes here.
PAC0 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump