Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 03-07-2013, 12:24 PM #1
xSHADOWxOPSxSOILDERx
Swagger-Jacking
 
Join Date: Jan 2013
Location: Chicago
Rotor Help!!!

hey guys so i bought a V3 rotor on here not to long ago and i don't know if it was like this when i bought it but i just noticed it now. when you turn the hopper on with no paint in it it runs fine, but as soon as you point the nose of the hopper twords the floor it starts to make this grinding/knocking sound like the spinny thing is brushing on something in the hopper. Is this normal? if not how can i fix it? Thanks!
xSHADOWxOPSxSOILDERx is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 03-07-2013, 12:31 PM #2
xSHADOWxOPSxSOILDERx
Swagger-Jacking
 
Join Date: Jan 2013
Location: Chicago
I made a video of this noise so anyone who might know what to do post your e-mail so i can send you the video.

Last edited by xSHADOWxOPSxSOILDERx : 03-07-2013 at 12:33 PM.
xSHADOWxOPSxSOILDERx is offline   Reply With Quote
Old 03-07-2013, 04:48 PM #3
ibunkerupwnd
it was all for lolz
 
ibunkerupwnd's Avatar
 
Join Date: Jun 2011
ibunkerupwnd supports Team VICIOUS
ibunkerupwnd has achieved Level 1 in PbNation Pursuit
ibunkerupwnd has achieved Level 2 in PbNation Pursuit
ibunkerupwnd has achieved Level 3 in PbNation Pursuit
Mine also does this. I think it's just the loose rotor in it.
__________________
THERE IS A FAT KID ON EVERY PAINTBALL TEAM. IF YOU ARE THAT FAT KID, PUT THIS IN YOUR SIG
HK Army
ibunkerupwnd is offline   Reply With Quote
Old 03-07-2013, 04:55 PM #4
xSHADOWxOPSxSOILDERx
Swagger-Jacking
 
Join Date: Jan 2013
Location: Chicago
yea, I think your right when you take the top shell of the loader off it sounds like the black dish is brushing up against the bottom panel. maybe a new black dish will solve it?
xSHADOWxOPSxSOILDERx is offline   Reply With Quote
Old 03-07-2013, 04:56 PM #5
AJolliff
R doz my balls on ur fac?
 
AJolliff's Avatar
 
Join Date: Jul 2009
Location: where I am
Have you taken the top part off to get a close look at the whole mechanism while it's on? It sounds like something that holds the blades in one spot might be loose or gone.

Could just be a loose or missing screw.

You can email me a vid at AJolliff88@yahoo.com
__________________
Negative feedback pending since 3/12/14
AJolliff is online now   Reply With Quote
Old 03-07-2013, 04:56 PM #6
xSHADOWxOPSxSOILDERx
Swagger-Jacking
 
Join Date: Jan 2013
Location: Chicago
I don't even know if its worth it cuz its only when my gun is pointing down and I'm never shooting like that.
xSHADOWxOPSxSOILDERx is offline   Reply With Quote
Old 03-07-2013, 04:58 PM #7
xSHADOWxOPSxSOILDERx
Swagger-Jacking
 
Join Date: Jan 2013
Location: Chicago
i just did and it still makes the noise with the panel removed
xSHADOWxOPSxSOILDERx is offline   Reply With Quote
Old 03-07-2013, 05:08 PM #8
AJolliff
R doz my balls on ur fac?
 
AJolliff's Avatar
 
Join Date: Jul 2009
Location: where I am
Can you see anything working differently while it's tilted?

Also you could take it fully apart to see if there are any signs of whatever it is rubbing
__________________
Negative feedback pending since 3/12/14
AJolliff is online now   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump