Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 02-17-2013, 04:31 AM #1
skvngr100
 
 
skvngr100's Avatar
 
Join Date: Feb 2010
Location: Inland Empire
Annual Supporting Member
skvngr100 owns a Planet Eclipse Geo
skvngr100 owns a Planet Eclipse Geo
skvngr100 supports DLX Technology
Ok I need help. I bought a luxe and when it's off I plug it in to charge the the light turns blue. When it's on I plug it in to charge there is blue lights for being on and red for charging I believe. No matter how long I charge the marker tells me it's at 75%. What can be wrong?

Last edited by skvngr100 : 02-17-2013 at 04:34 AM.
skvngr100 is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 02-17-2013, 08:41 AM #2
NastE-imp
 
 
NastE-imp's Avatar
 
Join Date: Jan 2012
Location: On a boat
NastE-imp has achieved Level 1 in PbNation Pursuit
I have this problem too. It appears to be stuck at 75%
__________________
Paintball Barn

NastE-imp is offline   Reply With Quote
Old 02-17-2013, 09:30 AM #3
poopresearch
Dr Nick
 
poopresearch's Avatar
 
Join Date: Feb 2007
Location: Seattle, WA
poopresearch plays in the PSP
poopresearch supports DLX Technology
Could be that your battery is on the outs... or it could be nothing. Electronics generally register battery level by looking at minute variations in battery voltage output. This method is very inaccurate.

When the Luxe says your battery level is 75%, it actually means little about how much electricity is stored, it means the battery is putting out slightly less voltage than what the board expects from a 100% full battery.

It's hard to explain if you haven't studies electricity in a physics class, but if the Luxe works, I wouldn't worry about it too much. You could also try the spare battery the Luxe comes with.
__________________
DBS FLOOD
Formerly of DBS Kidz 2, DBSPaintball.com and DBS Titans
poopresearch is offline   Reply With Quote
Old 02-17-2013, 10:21 AM #4
littleloopy15
 
 
littleloopy15's Avatar
 
Join Date: Jul 2011
littleloopy15 owns a Planet Eclipse Ego
littleloopy15 plays in the APPA D3 division
littleloopy15 supports DLX Technology
75% lasts me an easy 2-3 practices. So dont worry about it
__________________
FOR SALE/TRADE
littleloopy15 is offline   Reply With Quote
Old 02-17-2013, 10:41 AM #5
skvngr100
 
 
skvngr100's Avatar
 
Join Date: Feb 2010
Location: Inland Empire
Annual Supporting Member
skvngr100 owns a Planet Eclipse Geo
skvngr100 owns a Planet Eclipse Geo
skvngr100 supports DLX Technology
Bought gun used and didn't come with extra battery. But thanks for the info
skvngr100 is offline   Reply With Quote
Old 02-17-2013, 10:44 AM #6
NastE-imp
 
 
NastE-imp's Avatar
 
Join Date: Jan 2012
Location: On a boat
NastE-imp has achieved Level 1 in PbNation Pursuit
Quote:
Originally Posted by poopresearch
Could be that your battery is on the outs... or it could be nothing. Electronics generally register battery level by looking at minute variations in battery voltage output. This method is very inaccurate.

When the Luxe says your battery level is 75%, it actually means little about how much electricity is stored, it means the battery is putting out slightly less voltage than what the board expects from a 100% full battery.

It's hard to explain if you haven't studies electricity in a physics class, but if the Luxe works, I wouldn't worry about it too much. You could also try the spare battery the Luxe comes with.
Thanks for the quick response! With my luxe, I have tried multiple fresh batteries with no luck

It doesn't appear to affect the actual performance. But I figured if it was doing this (the 75%, it might be doing something else. I figured I wouldn't be the only one with the problem. But it appears to be the only issue...


And as for loopy's response: I don't think we are on the same page. To help understand, op and I can have charged or dead batteries. It will still say 75%.


Man I would like to hear that sexy voice say 100%. Maybe just change the voice sets so it doesn't bother me.
__________________
Paintball Barn

NastE-imp is offline   Reply With Quote
Old 02-17-2013, 08:54 PM #7
DanR
deutsch
 
DanR's Avatar
 
Join Date: Mar 2011
Location: cali
Annual Supporting Member
DanR plays in the PSP
DanR is an NCPA player
DanR plays in the APPA D4 division
DanR supports DLX Technology
DanR supports Empire
the battery is just older and has been recharged alot i shouldn't cause any issues and if it really bothers you get a newer black battery otherwise just stick with what you have
__________________
.
Mask Sale
DanR is offline   Reply With Quote
Old 02-17-2013, 10:46 PM #8
NastE-imp
 
 
NastE-imp's Avatar
 
Join Date: Jan 2012
Location: On a boat
NastE-imp has achieved Level 1 in PbNation Pursuit
Quote:
Originally Posted by DanR
the battery is just older and has been recharged alot i shouldn't cause any issues and if it really bothers you get a newer black battery otherwise just stick with what you have


Thanks poopresearch! And danr!
__________________
Paintball Barn


Last edited by NastE-imp : 02-18-2013 at 11:19 AM.
NastE-imp is offline   Reply With Quote
Old 02-23-2013, 08:21 PM #9
skvngr100
 
 
skvngr100's Avatar
 
Join Date: Feb 2010
Location: Inland Empire
Annual Supporting Member
skvngr100 owns a Planet Eclipse Geo
skvngr100 owns a Planet Eclipse Geo
skvngr100 supports DLX Technology
Found out not battery but USB cable doesn't put enough charge to battery. When I tried the home plug in I got a full charge.
skvngr100 is offline   Reply With Quote
Old 02-24-2013, 12:57 PM #10
jagarbosse
DYEmaster
 
jagarbosse's Avatar
 
Join Date: Jan 2005
Location: Sweden, my humble Castle
The reason - I think - is most likely that first of all that the USB output voltage is only 5V and the second thing is that the amp's output is way to low to charge the battery.

If you look at the wall charger it says 8,4V(I think) output, which is twice the uhmpf from the USB.
Somewhere it says that the USB for the comp is only for firmware updates.
__________________
Bosses Boob Hunters; squeez them boobays
jagarbosse is offline   Reply With Quote
Old 02-24-2013, 05:27 PM #11
skvngr100
 
 
skvngr100's Avatar
 
Join Date: Feb 2010
Location: Inland Empire
Annual Supporting Member
skvngr100 owns a Planet Eclipse Geo
skvngr100 owns a Planet Eclipse Geo
skvngr100 supports DLX Technology
Oh ok. When I bought mine it was used and had no wall charger just USB . Ha ha I bought new board , and battery just to find it out. But I got real good deal so no worries.
skvngr100 is offline   Reply With Quote
Old 05-17-2013, 09:48 AM #12
Pete32
---> Rob S.
 
Pete32's Avatar
 
Join Date: Mar 2003
Location: *So Tex*
Pete32 is a Supporting Member
 has been a member for 10 years
Pete32 plays in the PSP
Pete32 is reppin' sidebar 4 life
Mine having same issue.
bought a 2013 luxe brand new from factory.

-original battery installed was dead.
-backup battery was 75% and still remains at 75% after charging from wall socket for several hours.

:/
__________________
Old Feedback
#familyheartvictory
Animal Factory
#25
Pete32 is offline   Reply With Quote
Old 05-17-2013, 02:07 PM #13
braveboys85
 
 
braveboys85's Avatar
 
Join Date: May 2011
Location: NC
braveboys85 plays in the PSP
braveboys85 plays in the APPA D3 division
Quote:
Originally Posted by Pete32 View Post
Mine having same issue.
bought a 2013 luxe brand new from factory.

-original battery installed was dead.
-backup battery was 75% and still remains at 75% after charging from wall socket for several hours.

:/

It appears luxe got some bad chargers sir. I have two brand new 2.0s with bad chargers. Call dlx and they will send u a new one.
__________________
R.I.P BAD MOJO
R.I.P BR BOYZ
REPPIN DM-MAFIA
braveboys85 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump