Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 01-27-2013, 11:09 AM #1
djtail
 
 
Join Date: Mar 2011
djtail owns a Planet Eclipse Geo
djtail is for the Gunfight
fsdo 2013

Hi!

i just got my demon back from the uppgrading to 2013 internals....

when i gas it up the bolt don't travel all the way back... you have to push it with ur finger soe it goes all the way back....

if i fire without pushing the bolt back i got fsdo....

if i take out the spring it works, soe what does the spring do?

any one now how to solve this problem?

i have tried to change the o-ring on the boltguide (011)
djtail is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 01-28-2013, 02:31 AM #2
djtail
 
 
Join Date: Mar 2011
djtail owns a Planet Eclipse Geo
djtail is for the Gunfight
recorded a video to show what i mean:

djtail is offline   Reply With Quote
Old 01-28-2013, 01:10 PM #3
krazynuttz23
 
 
krazynuttz23's Avatar
 
Join Date: Nov 2008
actually kind of covered this. I posted a similar thread. Try relubing the bolt first. If still having fsdo. try changing the 3 021 can orings to polyurethane. That finally solved the problem for me
krazynuttz23 is offline   Reply With Quote
Old 01-28-2013, 01:30 PM #4
djtail
 
 
Join Date: Mar 2011
djtail owns a Planet Eclipse Geo
djtail is for the Gunfight
Quote:
Originally Posted by krazynuttz23 View Post
actually kind of covered this. I posted a similar thread. Try relubing the bolt first. If still having fsdo. try changing the 3 021 can orings to polyurethane. That finally solved the problem for me
i did see ur thread and have tried out all that got mentiond there. but still the same
djtail is offline   Reply With Quote
Old 01-28-2013, 02:04 PM #5
FRANKTHETANKCONNELL
NEW ENGLAND AVALANCHE
 
FRANKTHETANKCONNELL's Avatar
 
Join Date: Oct 2007
Location: Florida
FRANKTHETANKCONNELL is a Professional paintball player
FRANKTHETANKCONNELL works for a Paintball manufacturer
FRANKTHETANKCONNELL donated to help Peyton Trent
FRANKTHETANKCONNELL is playing at Living Legends III
FRANKTHETANKCONNELL is for the Gunfight
FRANKTHETANKCONNELL is for the Gunfight
You need to change the 011 on the bolt guide tip. Unless you bent it the bolt guide
__________________
New England Avalanche 2013 Sponsors
New England Avalanche

GI | Vanguard Demon | NXE | Stiffi Barrels | Ninja Paintball | Virtue | Exalt |
GXG | RAZA | OXCC | Sly | Boston Paintball |

Have you shot a Vanguard Demon or Creed yet?
FRANKTHETANKCONNELL is offline   Reply With Quote
Old 01-28-2013, 03:23 PM #6
Mattcar
 
 
Mattcar's Avatar
 
Join Date: Aug 2006
Mattcar is for the Gunfight
Mattcar is for the Gunfight
My gun was doing this at first, but the shuttle was on the wrong side,
__________________
I buy your Markers and gears
http://www.pbnation.com/showthread.php?t=3742888

WTB 08 Invert Digit camo pants Army patern, LARGE,
Mattcar is offline   Reply With Quote
Old 01-29-2013, 01:47 AM #7
djtail
 
 
Join Date: Mar 2011
djtail owns a Planet Eclipse Geo
djtail is for the Gunfight
changed the boldguide o-ring again... and that did the trick
djtail is offline   Reply With Quote
Old 01-30-2013, 09:01 AM #8
krazynuttz23
 
 
krazynuttz23's Avatar
 
Join Date: Nov 2008
I noticed that after a day of play and cleaning the gun, I have to remove the bolt guide oring and put it back on, or change it out, if not I get a small leak. Weird
krazynuttz23 is offline   Reply With Quote
Old 01-30-2013, 03:35 PM #9
spatanen
 
 
Join Date: Jul 2011
i wonder if you can check the quality of the 011 oring by doing the vacum test as the 2012 guide, or is that not enough on the 2013???
spatanen is offline   Reply With Quote
Old 01-30-2013, 09:00 PM #10
krazynuttz23
 
 
krazynuttz23's Avatar
 
Join Date: Nov 2008
i think it might be a problem with the bolt guide itself. sent my gun to frank and he replaced the 011 oring and worked fine until i cleaned and lubed it again then small leak is back. Had to keep changing the 011 oring until the leak stopped. ????
krazynuttz23 is offline   Reply With Quote
Old 01-31-2013, 02:17 PM #11
MstrKey
 
 
Join Date: Aug 2001
Location: SSM, Ontario, Canada
MstrKey is a founding member
 has been a member for 10 years
MstrKey is for the Gunfight
MstrKey supports our troops
Hmmm is it possible the springs are not sitting 100% flush? If they were to buckle a bit, it could cause the bolt to ride the guide oring in an uneven fashion. That might wear the orings down quick. Of course changing the oring out would solve the problem for a while, until you wore the new one down again.

Anyone have a pic of the spring? Is it ground down to sit perfectly flat on the ends? Do the coils finish at the same spot on both ends? No demon here.....just thinking about what could cause these #11 guide oring failures.
__________________

ETEK 3LT, with 14" critical .680 barrel and cure 3 + bolt F/S

DM12 red with matching Boomy F/s
MstrKey is online now   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump