Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 01-11-2013, 10:17 AM #1
blitz121
 
 
blitz121's Avatar
 
Join Date: May 2008
Location: Salina, KS
blitz121 helped look for balloons
blitz121 owns a Planet Eclipse Ego
blitz121 supports Sherwood Forest
blitz121 has achieved Level 1 in PbNation Pursuit
T8 trigger does not catch

So, it worked yesterday, I broke a ball in the gun so just stripped it so I started to understand the guns function. Unfortunately when I slapped it all back together squeeze the trigger and nothing. It really feels like the mechanism does not catch on anything. If I wobble the trigger around sometimes I hear a "click" and then it will shoot once. Has anyone experienced anything like this before?
__________________
KC ELITE
Elite Sports Raiders
Raid, pillage, and plunder

XTC social crew
Elite Sports
Elite Sports Complex
blitz121 is online now   Reply With Quote
Old 01-11-2013, 01:19 PM #2
viper0687
BLACK OPS LEGION COMMAND
 
viper0687's Avatar
 
Join Date: Aug 2011
Location: tyler, tx
You probably didn't install the bolt right. If you push it all the way to the back, it won't be caught by the trigger. You must disassemble it and put the bolt about halfway down the shaft instead of all the way down
viper0687 is offline   Reply With Quote
Old 01-11-2013, 02:23 PM #3
blitz121
 
 
blitz121's Avatar
 
Join Date: May 2008
Location: Salina, KS
blitz121 helped look for balloons
blitz121 owns a Planet Eclipse Ego
blitz121 supports Sherwood Forest
blitz121 has achieved Level 1 in PbNation Pursuit
alright I will try that when I get home, thanks Viper.
__________________
KC ELITE
Elite Sports Raiders
Raid, pillage, and plunder

XTC social crew
Elite Sports
Elite Sports Complex
blitz121 is online now   Reply With Quote
Old 01-11-2013, 02:26 PM #4
viper0687
BLACK OPS LEGION COMMAND
 
viper0687's Avatar
 
Join Date: Aug 2011
Location: tyler, tx
No problem, I've done it before too lol
viper0687 is offline   Reply With Quote
Old 01-11-2013, 05:32 PM #5
splatthetick
 
 
splatthetick's Avatar
 
Join Date: Jan 2010
Location: PDX Oregon
we all have!!!
splatthetick is offline   Reply With Quote
Old 01-15-2013, 08:46 AM #6
blitz121
 
 
blitz121's Avatar
 
Join Date: May 2008
Location: Salina, KS
blitz121 helped look for balloons
blitz121 owns a Planet Eclipse Ego
blitz121 supports Sherwood Forest
blitz121 has achieved Level 1 in PbNation Pursuit
been a little busy at work haven't been able to touch the t8 for a bit, I will try putting the bolt halfway down and see how that fairs.
__________________
KC ELITE
Elite Sports Raiders
Raid, pillage, and plunder

XTC social crew
Elite Sports
Elite Sports Complex
blitz121 is online now   Reply With Quote
Old 01-15-2013, 04:00 PM #7
Unlucky_Irish
 
 
Unlucky_Irish's Avatar
 
Join Date: Apr 2011
Location: Chicagoland
You can just leave it all the way forward and then when you install the spring/barrel it will set itself. Thats what I do, just slide it forward through the long thin oval hole on the bottom and finish putting it together.
Unlucky_Irish is offline   Reply With Quote
Old 01-15-2013, 05:24 PM #8
ousooners
 
 
ousooners's Avatar
 
Join Date: Mar 2011
Location: Daytona Beach FL
ousooners owns a Planet Eclipse Etha
ousooners has achieved Level 1 in PbNation Pursuit
ousooners has achieved Level 2 in PbNation Pursuit
My t9 is doing that. I bought it used for 120 from a guy because he said it won't shoot and I took it home and cleaned it but still won't shoot. I did push the bolt forward too and nothing. I do flick the trigger back fast and it will work. I think it doesn't have enough force to push it I guess. I'm not sure I'm still new to tiberius pistols.
ousooners is offline   Reply With Quote
Old 01-15-2013, 05:52 PM #9
viper0687
BLACK OPS LEGION COMMAND
 
viper0687's Avatar
 
Join Date: Aug 2011
Location: tyler, tx
I know the spring is smaller on one end than the other and that may be another problem, though I've never gotten it backwards.. Hard to say another problem with those symptoms being anything else other than the bolt/spring incorrectly installed that comes to mind if you know there is air pressure getting to it
viper0687 is offline   Reply With Quote
Old 01-15-2013, 08:10 PM #10
ousooners
 
 
ousooners's Avatar
 
Join Date: Mar 2011
Location: Daytona Beach FL
ousooners owns a Planet Eclipse Etha
ousooners has achieved Level 1 in PbNation Pursuit
ousooners has achieved Level 2 in PbNation Pursuit
I just found out after taking mine apart that the spring on the trigger rod is loose and that is keeping it from going all the way forward to catch on the bolt. I dont know if that helps or is your problem. You can find them on rockstartactical.com for 1.00
ousooners is offline   Reply With Quote
Old 01-16-2013, 08:52 AM #11
blitz121
 
 
blitz121's Avatar
 
Join Date: May 2008
Location: Salina, KS
blitz121 helped look for balloons
blitz121 owns a Planet Eclipse Ego
blitz121 supports Sherwood Forest
blitz121 has achieved Level 1 in PbNation Pursuit
oh, theres a spring on the trigger rod? that would be the problem then, do you possibly have a link to that?
__________________
KC ELITE
Elite Sports Raiders
Raid, pillage, and plunder

XTC social crew
Elite Sports
Elite Sports Complex
blitz121 is online now   Reply With Quote
Old 01-16-2013, 03:22 PM #12
JustinTA
Justin
 
JustinTA's Avatar
 
Join Date: Nov 2012
Location: Fort Wayne, IN
Annual Supporting Member
JustinTA works for a Paintball manufacturer
Here's how the reg should be assembled:

http://youtu.be/e_SppACs-Ws

Here's the link to the rotator return spring:

http://www.rockstartactical.com/Tibe...tib-sprg04.htm

It should not be loose.
JustinTA is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump