Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Closed Thread
 
Thread Tools
Old 12-29-2012, 03:28 PM #1
binaryterror
Static?
 
binaryterror's Avatar
 
Join Date: Jun 2005
Location: Ohio
binaryterror is a Supporting Member
Razer Naga left click stopped working?

I've had my Naga since it came out and it never had any problems, yet I plug it back in today and the left click doesn't work. Everything else on the mouse works fine still... The button still 'clicks', it just doesn't do anything on the screen (if that makes sense). I tried uninstalling and reinstalling the software and I noticed the left click is faded out and I can't bind it to anything? I have a pic below showing this. Very odd, anyone had this problem? Hopefully the mouse isn't garbage now!

__________________
"A government big enough to give you everything that you want, is big enough to take away everything that you have." - Thomas Jefferson

“When the people fear their government, there is tyranny; when the government fears the people, there is liberty.” – Thomas Jefferson

Last edited by binaryterror : 12-29-2012 at 03:30 PM.
binaryterror is offline  
Old Sponsored Links Remove Advertisement
Advertisement
Old 12-29-2012, 03:30 PM #2
Evac.
Wolfpack
 
Evac.'s Avatar
 
Join Date: Sep 2009
Location: Queens
Annual Supporting Member
Evac. is a Paintball photographer
Evac. plays in the PSP
lolrazer

RMA time.
Evac. is offline  
Old 12-29-2012, 03:33 PM #3
Cmizzle
Full Time Tape Head
 
Cmizzle's Avatar
 
Join Date: Oct 2006
Man im still rocking the MX518 that I bought back in 2005
Cmizzle is offline  
Old 12-29-2012, 03:37 PM #4
binaryterror
Static?
 
binaryterror's Avatar
 
Join Date: Jun 2005
Location: Ohio
binaryterror is a Supporting Member
I think I am past a RMA. I have had this mouse for like 4 years.
__________________
"A government big enough to give you everything that you want, is big enough to take away everything that you have." - Thomas Jefferson

“When the people fear their government, there is tyranny; when the government fears the people, there is liberty.” – Thomas Jefferson
binaryterror is offline  
Old 12-29-2012, 11:14 PM #5
AzaTuR
¼ Skill ¾ My Shocker™
 
AzaTuR's Avatar
 
Join Date: Aug 2008
Location: UpTown Dallas
Annual Supporting Member
AzaTuR supports Cereal Killerz 2
AzaTuR owns a Planet Eclipse Ego
AzaTuR owns a Planet Eclipse Ego
AzaTuR owns a Planet Eclipse Ego
AzaTuR supports Team VICIOUS
AzaTuR supports Team VICIOUS
AzaTuR supports Team VICIOUS
sweet mouse
__________________
6 Year ASM Council OG
&
The Shocker Owners Group
AzaTuR is offline  
Old 12-29-2012, 11:32 PM #6
Xdanisx
Team up! Team Up!
 
Xdanisx's Avatar
 
Join Date: Oct 2012
Location: MA
Xdanisx posts videos on PbNation
Xdanisx has perfected Level 1 in PbNation Pursuit
Xdanisx has achieved Level 3 in PbNation Pursuit
Try using it on another pc and that'll proove whether it's the mouse or just the drivers. Perhapse you did not uninstall them correctly. If it's fine on another pc without razor drivers, then use Revo to uninstal the drivers and then reinstall the newest drivers.

I don't know how the Razor Naga works, but with my G9x, you can create different profiles. Perhaps something accidentally disabled the button in one profile?

EDIT: This dude had a similar issue. Here's what he did to fix it:

Quote:
download the latest firmware update from the site i believe its 1.13 its just the installer and not the actual firmware update to update your mouse...

1. go into progams/razer/naga/firmware updater
2. disconnect ur mouse and hold the left right and mouse 3 buttons then reconnect ur mouse and click next on the screen (it should detect your mouse and start its update)
3. after installer is done it asks you to replug your mouse in plug it back in and it should work fine all ur keybindings that u have on ur software should work and be able to use
__________________
Signature

Last edited by Xdanisx : 12-29-2012 at 11:42 PM.
Xdanisx is offline  
Old 12-29-2012, 11:46 PM #7
mymutter
I crack myself up!
 
mymutter's Avatar
 
Join Date: Dec 2008
Location: the 847
mymutter is reppin' sidebar 4 life
I use the R.A.T. 7 and never have any problems. it replaced my G5 which is still going strong on my backup PC. I heard bad things about razer, and when I found they cannot even put Cherry switches in their mechanical keyboards, had to say no when offered the NAGA.

I guess if you play WOW, it's a decent mouse based on features, but ....
mymutter is offline  
Old 12-30-2012, 01:41 AM #8
gun slayer
Yes, I'm an *******.
 
gun slayer's Avatar
 
Join Date: Jan 2005
Location: DFW
gun slayer is a Supporting Member
gun slayer has achieved Level 1 in PbNation Pursuit
Quote:
Originally Posted by binaryterror View Post
I think I am past a RMA. I have had this mouse for like 4 years.
the naga came out in august 2009
__________________
94% of people suck at basic math. If you're part of the 8% that dosen't, put this in your sig.
gun slayer is offline  
Old 01-13-2013, 02:19 AM #9
Father of Lies (Banned)
Belle Humble
 
Join Date: Jan 2013
Location: Ann Arbor, MI
Good luck with the RMA, Razer is the absolute worst at it. When I moved, my mouse broke somehow. I could hear weights or something like it rattling around in it. So I emailed them. After waiting several days, they finally wrote back to take a picture of the mouse with the cord cut. The first set of pics I took weren't good enough. Several more days later, they finally approve it. About 2 days later I got an email they shipped it. 5 days later I got it. The new one skips around and is broke. And I am still waiting on them to ship me a replacement for my replacement. I ended up picking up a Deathadder today just so I could game again. I love the product, I just hate their awful customer service. I'm also pretty sure they're not in an English-based country.

I would still go for it, they just make you cut the cord at the base. It's worth a shot, save yourself 80 bucks. (65ish if you buy it from Amazon).

Last edited by Father of Lies : 01-13-2013 at 02:22 AM.
Father of Lies is offline  
Old 03-18-2013, 03:31 PM #10
grizzlysaurusrex
 
 
Join Date: Mar 2013
Quote:
Originally Posted by Xdanisx View Post
Try using it on another pc and that'll proove whether it's the mouse or just the drivers. Perhapse you did not uninstall them correctly. If it's fine on another pc without razor drivers, then use Revo to uninstal the drivers and then reinstall the newest drivers.

I don't know how the Razor Naga works, but with my G9x, you can create different profiles. Perhaps something accidentally disabled the button in one profile?

EDIT: This dude had a similar issue. Here's what he did to fix it:
I had the exact same problem the OP had. That screenshot looked exactly like what my screen was showing. I just wanted to post and say that this method solved my problem and my mouse is now working again. Thank you!
grizzlysaurusrex is offline  
Old 07-22-2013, 07:37 PM #11
scartail
 
 
Join Date: Jul 2013
I had the same problem with my boyfriends mouse. The left and right click didn't work, (the right click still doesn't work) but what I did was I unbound button 3 which was scroll click and bound it to be left click.

Last edited by scartail : 07-22-2013 at 07:38 PM. Reason: Picture would not show up.
scartail is offline  
Old 07-22-2013, 08:05 PM #12
Supra_MKIII
Check your math.
 
Supra_MKIII's Avatar
 
Join Date: Nov 2005
Location: Not what you think
Quote:
Originally Posted by scartail View Post
I had the same problem with my boyfriends mouse. The left and right click didn't work, (the right click still doesn't work) but what I did was I unbound button 3 which was scroll click and bound it to be left click.
Are you kidding me?
__________________
ST:Tech- We write Haikus. Also, THE PLAGUE

2001 Viggen // Stage 1 Oil Injection // Stage 3 Exhaust Leak // Wet Clutch Mod
Supra_MKIII is offline  
Closed Thread


Thread Tools

Posting Rules
Forum Jump