Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 01-06-2013, 02:26 PM #1
nico450r
 
 
nico450r's Avatar
 
Join Date: Jul 2011
Location: South Dallas
nico450r is playing at Living Legends VI
nico450r owns a Planet Eclipse Geo
nico450r plays in the APPA D5 division
Geo 3 Velocity up and down

Hey guys, I have had my geo 3 for a few months now with the shot counter at 26,xxx. My gun has never been real consistant over the chrono, but I figured it needed to be broken in. I was trying to chrono my gun yesterday and it was all over the place. On average it was it was around 290 fps but spiked up to over 305 and as low as 265. I have a good ball to barrel match, tried shooting different paint (2 different kinds of Evil). I re-lubed the whole gun and made sure not to overlube the o-rings(just look wet). I tryed to see if changing my sfr adj. would make a different but it didnt.

If you have any ideas please fill me in. Thanks...
nico450r is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 01-06-2013, 04:39 PM #2
TeamConcussion#9
 
 
TeamConcussion#9's Avatar
 
Join Date: Feb 2010
TeamConcussion#9 owns a Planet Eclipse Ego
whens the last time you lubed er up? How old is the battery and is it a top quality battery?
__________________
Jake Smart
Factory Certified Planet Eclipse Tech

Team CONCUSSION Facebook
Special thanks to our Sponsors
--GoBigPaintball-store
--GoBigPaintball-Facebook
--GOODBURGER welcome to good burger, home of the good burger...
TeamConcussion#9 is offline   Reply With Quote
Old 01-06-2013, 04:44 PM #3
patrickusaf08
 
 
Join Date: Oct 2008
Annual Supporting Member
patrickusaf08 owns a Planet Eclipse CSL
patrickusaf08 owns a Planet Eclipse Geo
patrickusaf08 owns a Planet Eclipse Ego
patrickusaf08 supports Team VICIOUS
patrickusaf08 supports Pev's Paintball
patrickusaf08 supports DLX Technology
Sounds like its time to service the reg. maybe the reg seat.
patrickusaf08 is offline   Reply With Quote
Old 01-06-2013, 06:15 PM #4
nico450r
 
 
nico450r's Avatar
 
Join Date: Jul 2011
Location: South Dallas
nico450r is playing at Living Legends VI
nico450r owns a Planet Eclipse Geo
nico450r plays in the APPA D5 division
I lubed the gun the same day I tried to get the chrono under conrol. And it has the factory battery in it. The battery guage shows just under full power.
nico450r is offline   Reply With Quote
Old 01-06-2013, 06:33 PM #5
frenchy2475
 
 
Join Date: Jul 2009
Location: Gloucestershire, UK
frenchy2475 owns a Planet Eclipse Geo
frenchy2475 owns a Planet Eclipse Geo
frenchy2475 owns a Planet Eclipse Ego
I would try a brand new battery. I wouldn't rely on the gauge.
frenchy2475 is offline   Reply With Quote
Old 01-06-2013, 06:42 PM #6
nico450r
 
 
nico450r's Avatar
 
Join Date: Jul 2011
Location: South Dallas
nico450r is playing at Living Legends VI
nico450r owns a Planet Eclipse Geo
nico450r plays in the APPA D5 division
I will put a new battery in it. I just dont think it will fix anything because it has been like this since it was new. But if it works that would be cool.
nico450r is offline   Reply With Quote
Old 01-06-2013, 08:44 PM #7
minimag03
 
 
minimag03's Avatar
 
Join Date: Aug 2004
Location: Bluefield, WV
 has been a member for 10 years
minimag03 is an NCPA player
What type of tank are you using? When was the last time you serviced the tanks reg and checked its output pressure/consistency/recharge rate?
__________________
Old Feeback
minimag03 is offline   Reply With Quote
Old 01-06-2013, 09:10 PM #8
TeamConcussion#9
 
 
TeamConcussion#9's Avatar
 
Join Date: Feb 2010
TeamConcussion#9 owns a Planet Eclipse Ego
First rule when having problems like these is to replace the battery no matter what the battery level says. Make sure its a quality battery also, very important.
__________________
Jake Smart
Factory Certified Planet Eclipse Tech

Team CONCUSSION Facebook
Special thanks to our Sponsors
--GoBigPaintball-store
--GoBigPaintball-Facebook
--GOODBURGER welcome to good burger, home of the good burger...
TeamConcussion#9 is offline   Reply With Quote
Old 01-08-2013, 12:46 PM #9
CrusaderPB
Field, Pro Shop & Repairs
 
CrusaderPB's Avatar
 
Join Date: Feb 2010
Location: Fairless Hills, PA
Annual Supporting Member
CrusaderPB owns a Planet Eclipse Ego
CrusaderPB supports Bob Gurnsey
CrusaderPB supports our troops
CrusaderPB has perfected Level 1 in PbNation Pursuit
CrusaderPB has achieved Level 3 in PbNation Pursuit
CrusaderPB supports Empire
To mirror above, yes, use a new high-quality alkaline battery. Why get a marker worth hundreds if you won't use batteries that are $3.50?

What is your dwell at? Depending on location, weather conditions may require you raise your dwell a bit. Also, check your SFR; it may help to raise it. If not...

The SL3 Inline Regulator may need servicing. The regulator piston uses a size 16 o-ring.. remove the old one (even if there is no visible wear), clean out the groove, and install a new one with proper lubrication. Your reg seal may also be worn. Refer to page 56 of the manual here:

http://files.planeteclipseb2b.com/ma...-MANUAL-EN.pdf
__________________
Crusader Paintball -Serving Philadelphia, Trenton and Princeton
225 Lincoln Highway
Fairless Hills PA 19030 Phone: 215-949-4600
Now a Planet Eclipse Service Center

Like us on Facebook! Follow us on Twitter! Subscribe to our Thread!
CrusaderPB is offline   Reply With Quote
Old 01-09-2013, 10:00 AM #10
vxmaniac
 
 
vxmaniac's Avatar
 
Join Date: Dec 2008
vxmaniac has achieved Level 1 in PbNation Pursuit
just to collate everything together id recommend (as others have said) the following things to do in order

1. new brand name battery
2. board factory reset
3. check others arent having similiar fluctuations (meaning its the paint)
4. check detents and replace if necessary
5. try a different barrel
6. try a different bottle (or a couple, including different output pressures)
7. do a full pull down and inspect all orings and relube with pe grease or a decent dow33 based lube (sleek, dye etc)
8. check hpr reg seat and/or replace hpr seat
9. dwell tune (to much or to little dwell can sometimes mess with velocity) as well as adjusting the sfr

last resorts
- full oring rebuild: sfr, bolt and hpr
- remove solenoid and check for any damage etc.

if none of these work i would recommend having a planet eclipse tech/tech centre look at it...
vxmaniac is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump