Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 01-07-2013, 06:24 PM #1
whyuuucockin
 
 
Join Date: Dec 2012
Help

I have a worrframe on my prostock and the bolt cycles fine but no fire its timed and it fires when the grips off but when there on it doesnt
whyuuucockin is offline   Reply With Quote
Old 01-07-2013, 08:56 PM #2
Darkapollo
 
 
Darkapollo's Avatar
 
Join Date: Sep 2007
Location: New Cumberland, PA
Keep top front the grip screw out. Its too long and jamming up the sear. Very common.
__________________
Darkapollo is offline   Reply With Quote
Old 01-07-2013, 09:21 PM #3
Rebel_816
Don't eat that....
 
Rebel_816's Avatar
 
Join Date: Apr 2007
Location: Lynn, AR
yep. make sure the top grip screws arent on too tight. they can rub agains the sear solenoid and keep it from moving sometimes. sear noid might also need a little cleaning if its gunked up, just pull it out and take it apart and wipe it off if need be. dont put any lube or anything on it when you put it back in.
__________________
Rapper
Rebel_816 is offline   Reply With Quote
Old 01-08-2013, 08:31 PM #4
whyuuucockin
 
 
Join Date: Dec 2012
The solanoid only drops when you barley pull on the cocking rod
whyuuucockin is offline   Reply With Quote
Old 01-08-2013, 08:51 PM #5
Rebel_816
Don't eat that....
 
Rebel_816's Avatar
 
Join Date: Apr 2007
Location: Lynn, AR
im not quite sure what you mean. you shouldnt need to pull on the cocking rod at all....
__________________
Rapper
Rebel_816 is offline   Reply With Quote
Old 01-08-2013, 09:51 PM #6
whyuuucockin
 
 
Join Date: Dec 2012
My back block isngetting anoned so I got the Worrframe wile it's gone and I was testing it and when I slightly pull on it the solanoidnd drops and it fires but the solanoid gets stuck
whyuuucockin is offline   Reply With Quote
Old 01-09-2013, 12:33 AM #7
Darkapollo
 
 
Darkapollo's Avatar
 
Join Date: Sep 2007
Location: New Cumberland, PA
Quote:
Originally Posted by whyuuucockin View Post
My back block is getting annoed so I got the Worrframe while it's gone. I was testing it and when I slightly pull on it the solenoid, it drops and fires but the solenoid gets stuck
FIXED.
You either need to give us all of the info or give us the correct info.
First you say it fires with out the grips, which is common when the front screws are too long. Next you say you need to pull on the cocking knob to get it to fire.
My suggestion is to send it to someone who knows what they are doing so they can fix it for you and then dont mess with it.

Barring that, there are one or two (typically one, but some have two) tiny lock screws in the frame that clamp the solenoid in place. They arent needed and can also cause jamming issues.
__________________
Darkapollo is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump