Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 01-03-2013, 04:49 PM #1
paintlickers321
 
 
paintlickers321's Avatar
 
Join Date: Jan 2012
Location: ny
paintlickers321 owns a Planet Eclipse Geo
paintlickers321 owns a Planet Eclipse Etek
paintlickers321 is for the Gunfight
Help!! Geo 2.1 Problem

Hello, today I received my Geo 2.1 in a trade. I went in my backyard to shoot and it shot one bullet and then wouldnt allow me to shoot another. Around every 3-4 seconds it would shoot one, so I went and tighten every screw and adjusted my trigger to make sure all the screws were there, and my solenoid wasnt closed shut. Then I came back out and shot, and it didnt even shoot. Do you know what is wrong, or if i have to do anything to it. When i contacted the dealer i asked him if the gun worked fine and what mode he shot it on, and he said it was completely fine shot it on ramping.
paintlickers321 is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 01-03-2013, 05:28 PM #2
FiresofSirius
Let the Galaxy Burn
 
FiresofSirius's Avatar
 
Join Date: Mar 2006
Location: Boston
FiresofSirius donated to help Peyton Trent
FiresofSirius owns a Planet Eclipse Geo
FiresofSirius is reppin' sidebar 4 life
Did you install a fresh battery? I had a similar issue with my GEO and a new battery fixed it, even though the grip said it was at full charge. Odd I know, but give that a try if you haven't already.
FiresofSirius is offline   Reply With Quote
Old 01-03-2013, 05:36 PM #3
ThorsHammer45
 
 
ThorsHammer45's Avatar
 
Join Date: Aug 2010
Location: Chicago
Annual Supporting Member
ThorsHammer45 is BST Legit
ThorsHammer45 is playing at Living Legends V
ThorsHammer45 is playing at Living Legends VI
ThorsHammer45 is playing at Living Legends VII
ThorsHammer45 owns a Planet Eclipse Lv1
ThorsHammer45 supports Team VICIOUS
I had this same problem with mine. Make sure you put a fresh battery in and also make sure there is enough lube on it because mine didnt have enough lube. Put all the settings back to stock and make sure its lubed well and fresh battery and it should work just fine.
__________________
NEED TO SELL GUNS FAST?
GA 68/4500
ThorsHammer45 is offline   Reply With Quote
Old 01-03-2013, 05:50 PM #4
paintlickers321
 
 
paintlickers321's Avatar
 
Join Date: Jan 2012
Location: ny
paintlickers321 owns a Planet Eclipse Geo
paintlickers321 owns a Planet Eclipse Etek
paintlickers321 is for the Gunfight
Quote:
Originally Posted by ThorsHammer45 View Post
I had this same problem with mine. Make sure you put a fresh battery in and also make sure there is enough lube on it because mine didnt have enough lube. Put all the settings back to stock and make sure its lubed well and fresh battery and it should work just fine.
it takes a long time for the solenoid to return
paintlickers321 is offline   Reply With Quote
Old 01-03-2013, 09:52 PM #5
BlazinBeast
 
 
BlazinBeast's Avatar
 
Join Date: Jan 2013
My Spyder did that. Have fun getting a new gun. I suggest something reliable like an etek 4 or an etha (I have both and I personally choose etha)
BlazinBeast is offline   Reply With Quote
Old 01-03-2013, 10:48 PM #6
BDidz
SFP
 
BDidz's Avatar
 
Join Date: Aug 2009
Location: Land Of Cold Air
Annual Supporting Member
BDidz is BST Legit
BDidz owns a Planet Eclipse Geo
BDidz owns a Planet Eclipse Geo
BDidz owns a Planet Eclipse Geo
BDidz supports our troops
BDidz plays in the APPA D4 division
BDidz is Legendary
Quote:
Originally Posted by BlazinBeast View Post
My Spyder did that. Have fun getting a new gun. I suggest something reliable like an etek 4 or an etha (I have both and I personally choose etha)
Haha a Geo is nothing like a spyder... If anything you might need to spend some money rebuilding the noid but it might be something even more simple like battery/orings/or lube. A friend of mines geo was having really bad fsdo problems so he replaced the pilot valve and that fixed it. Maybe that's your problem. If you have access to another geo id try swapping noids with it and seeing if that's what is causing the problem.
BDidz is offline   Reply With Quote
Old 01-04-2013, 03:44 AM #7
SpanksIPB
 
 
SpanksIPB's Avatar
 
Join Date: Dec 2009
Location: Ithaca, NY
SpanksIPB owns a Planet Eclipse Geo
SpanksIPB owns a Planet Eclipse Lv1
What type of hopper and tank where you using?
SpanksIPB is offline   Reply With Quote
Old 01-04-2013, 05:08 PM #8
paintlickers321
 
 
paintlickers321's Avatar
 
Join Date: Jan 2012
Location: ny
paintlickers321 owns a Planet Eclipse Geo
paintlickers321 owns a Planet Eclipse Etek
paintlickers321 is for the Gunfight
Quote:
Originally Posted by SpanksIPB View Post
What type of hopper and tank where you using?
i fixed it now. but i was using a ninja 50/45, and a dye rotor
paintlickers321 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump