Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 12-29-2012, 12:11 PM #1
hiofficr87
 
 
hiofficr87's Avatar
 
Join Date: Jul 2010
Location: Jarrettsville, MD
hiofficr87 plays in the PSP
hiofficr87 owns a Planet Eclipse Geo
hiofficr87 plays in the APPA D4 division
Critical trigger on VX issue

Ok so I got a critical trigger for my clone VX..the magnet is installed correctly but now when I put the pin through the trigger and try to tighten it the trigger freezes...I'm not cranking down on the threads or making it super tight I just don't get it...this is the second trigger and its doing the same thing ....HELP!!!!
hiofficr87 is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 12-29-2012, 02:52 PM #2
SHOOTNPOO
MACDEV MASTER US TECH
 
SHOOTNPOO's Avatar
 
Join Date: Mar 2008
SHOOTNPOO works for a Paintball manufacturer
SHOOTNPOO plays in the USPL
SHOOTNPOO posts videos on PbNation
Did you use both washers? I only use one in mine.
SHOOTNPOO is offline   Reply With Quote
Old 12-29-2012, 07:21 PM #3
blueshifty
RIP: Underĝath
 
blueshifty's Avatar
 
Join Date: Jun 2006
Location: Dallas, TX
I haven't been real happy with the fit of critical triggers lately, shimming it is the only way to take the play out then it binds. VP seems to have a little better fit for me.
__________________
Feedback: Old (+4)
blueshifty is offline   Reply With Quote
Old 12-29-2012, 08:21 PM #4
hamfz
 
 
Join Date: Jul 2012
Location: Austin, TX
I used a critical with both washers and no issue.
hamfz is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump