Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 12-22-2012, 10:10 AM #1
cpuwhiz22
 
 
Join Date: Jun 2012
Defective Smart Parts 9V Charger? GoG, Please Help!

Ok, so I got a "Smart Parts" charger kit a couple weeks ago from here:

http://www.rockstartactical.com/product_p/sp-9v-2pk.htm

However what showed up looked like a different charger. I figured maybe this is because GoG is not branding them as Smart Parts anymore. I am not sure.

Anyhow, after fully charging them when I tested them for the first time both gave a yellow flash when powering up my eXTCy, indicating they were low. I thought that maybe this was normal for rechargeables, but later I found out that wasn't the case since I left them on the charger again for some time and then tested them and then they flashed green. It's kind of crappy though since it seems sometimes the LEDs on the charger are yellow when there is a charging battery, but other time I put in a battery I know is low, and the LED is green. Additionally, the LEDs are green when there are no batteries in it, which seems odd to me, but could be normal.

Anyhow, at this point I am thinking I have a defective charger since yesterday I left both batteries on the charger all day. Both LEDs were green when I took the batteries off as I left for the field. I get to the field pop one in, and the marker wont even power on. It acted as if there were no batteries in it. I swapped it out with the other, and the other powered up and flashed green in the marker, but after only a game or so it was flashing yellow as if it was dying. Anyhow I continued to charge the other in the meantime, and was swapping the two periodically to get through the day.

Then I got home, and I put the batteries in the charger (knowing they are low from yesterday) and plugged it in and both LEDs on the charger are green, as if they are charged. I know they aren't and I am guessing if that's why I had issues yesterday. I am guessing the charger is a bit flaky and sometimes is thinking the batteries are charged (hence the green LED) and not charging them. So yesterday when I left for the field with them both allegedly fully charged, I am suspecting the one that was dead when I got there was actually not charging at all.

GoG, can you help a baller out? I bought these instead of Energizer or Duracell rechargeables since I have a GoG marker, so I figured this would be the best choice, however I am wondering if this is even a GoG/SP product I got, or if it's defective?

Here are some pictures. NOTE: The ones with the batteries in while it's plugged in were taken with batteries that I know are low since I haven't charged them since using them both yesterday. They were flashing yellow/red when putting them in my eXTCy.

http://publicfiles.sytechsolutions.net/sp_charger/




cpuwhiz22 is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 12-27-2012, 10:06 AM #2
cpuwhiz22
 
 
Join Date: Jun 2012
Just wanted to update everyone on this. Once again, GoG support is unbeatable. I sent them a link to this thread and asked if they could let me know what they thought, and here is the reply I got:

Quote:
Im not sure what the deal is with that charger. Im looking into it still. In the mean time give me your address and I will send you a red 2 bay charger.
Once again why I am super happy with my decision to get the eXTCy, and other GoG parts for it. I didn't even buy this charger combo directly from them, and here they are bailing me out. Lesson learned, next time I will go straight to the source

Thanks a million GoG!
cpuwhiz22 is offline   Reply With Quote
Old 12-29-2012, 10:51 AM #3
cpuwhiz22
 
 
Join Date: Jun 2012
The new one showed up today as promised! Awesome support GoG!

cpuwhiz22 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump