Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Closed Thread
 
Thread Tools
Old 11-05-2012, 10:17 PM #1156
jb6xb
FORD RACING!!!!
 
jb6xb's Avatar
 
Join Date: Aug 2012
Location: Rolla
jb6xb supports Team VICIOUS
jb6xb is an NCPA player
jb6xb plays in the APPA beginner division
jb6xb has achieved Level 2 in PbNation Pursuit
Just picked up a Hurricanes SL74, having really bad drop off once ramping kicks in, just rebuilt the reg, lpr, rammer, and asa, still having the problem, where should I start with replacements, dwell is at 13ms, Thank you in advance.
__________________
You gas up the marker, put on the gloves, strap on the mask, and walk onto the field.. it doesn't matter that you failed a test, that your girlfriend broke up with you last night, or that you got a ticket on the way there... your world is right for the next couple hours, this is your heaven on earth.. live it.. love it.. Paintball 4 life!

Missouri S&T Prestige Paintball
jb6xb is offline  
Old Sponsored Links Remove Advertisement
Advertisement
Old 11-05-2012, 11:03 PM #1157
PE_Ego9bunkerz
 
 
PE_Ego9bunkerz's Avatar
 
Join Date: Oct 2012
Location: Chino Hills
PE_Ego9bunkerz owns a Planet Eclipse Ego
PE_Ego9bunkerz has achieved Level 1 in PbNation Pursuit
Quote:
Originally Posted by jb6xb
Just picked up a Hurricanes SL74, having really bad drop off once ramping kicks in, just rebuilt the reg, lpr, rammer, and asa, still having the problem, where should I start with replacements, dwell is at 13ms, Thank you in advance.
Same thing happened to me with my ego9 when I got it. I did a factory reset, new battery, and cleaned and lubed the marker and it shot fine again. This may be a dumb question but are you sure your tank wasn't low?
PE_Ego9bunkerz is offline  
Old 11-06-2012, 03:26 AM #1158
Bill
Paintball Showcase
 
Bill's Avatar
 
Join Date: Nov 2001
Location: Paintball Showcase
Annual Supporting Member
Bill is a Supporting Member
Bill is a founding member
 has been a member for 10 years
Bill owns a Planet Eclipse Ego
- Try a new Energy, Duracell or Energizer battery. The gun needs a good amount of power to run the marker properly. A lessor brand of battery may read fully charged but doesn't have the upkeep to sustain the power needed to run the gun. This is the #1 cause of all issues in an EGO.
- Replace the #11 rammer oring. Even if it looks good. It will be the largest black oring towards the rear of the rammer.
- Set your dwell (14.0).
- QEV Diaphragm issue. Inside the QEV, between the blue and silver halves, is a rubber diaphragm. This part should be one piece. Make sure it is not ripped or cut (see page 63 in the manual).
- Check the HPR. Make sure it is assembled, lubed. Make sure there are 16 shim springs properly assembled. The shims are slightly bent. You want them opposing each other. )()()()()()()()(
- While you have the HPR apart, check the HPR Piston reg seat. Make sure it is there and not cracked (See page 44/45 of the manual). Perfect preesure would be 325 psi. It can be achieved by properly assembling it then spinning the adjuster screw all the way out and then 3.5 turns in. This will give you the approximte pressure.
- Check the LPR. Make sure both springs are present. There should be 5 pieces within the LPR. Starting from front: Adjuster screw, Adjuster piston, gold spring, Regulator piston and second gold spring. Both springs are the same. Put the adjuster screw flush to one turn out, see if this affects the velocity at all.
- While you have the LPR apart check the LPR piston seat. Looks just like the HPR piston but smaller. Seat is in the same area...
- ASA On/Off knob turned in to far? When you add your air system to the gun you want to turn the knob until you hear the initial gas transfer. Do not turn it more then one complete turn more or you will actually restrict the airflow coming out of your air system.
- Complete oring overhaul
Quote:
Originally Posted by jb6xb View Post
Just picked up a Hurricanes SL74, having really bad drop off once ramping kicks in, just rebuilt the reg, lpr, rammer, and asa, still having the problem, where should I start with replacements, dwell is at 13ms, Thank you in advance.
__________________
WWW.PAINTBALLSHOWCASE.COM

Certified NorthEast Eclipse Technician/Warranty Center!

Used Gun thread: EGO8s, DMs, Shockers, and more...
Bill is offline  
Old 11-06-2012, 03:29 AM #1159
Bill
Paintball Showcase
 
Bill's Avatar
 
Join Date: Nov 2001
Location: Paintball Showcase
Annual Supporting Member
Bill is a Supporting Member
Bill is a founding member
 has been a member for 10 years
Bill owns a Planet Eclipse Ego
Quote:
Originally Posted by FalconPunchKid View Post
Okay. I have an Ego10 that is my baby. I like it more then my 11.
But recently my screen stopped working. Over a 3 day period the pixels on the screen just started getting dimmer and dimmer to the point where you just can't see them.
The back light still works.
The marker works great and im thankfull that i had it locked in tournament mode.

I cleaned the marker and checked the connections.
It pretty much seems like it would need a new screen. Is that puasable?
I know the boards are rather expensive, but is it possible to replace just the screen at a low cost?
The screen on a 10 is interchangeable. You can get them from any PE tech

They usually go bad from excess oil or grease contact.
__________________
WWW.PAINTBALLSHOWCASE.COM

Certified NorthEast Eclipse Technician/Warranty Center!

Used Gun thread: EGO8s, DMs, Shockers, and more...
Bill is offline  
Old 11-06-2012, 03:30 AM #1160
Bill
Paintball Showcase
 
Bill's Avatar
 
Join Date: Nov 2001
Location: Paintball Showcase
Annual Supporting Member
Bill is a Supporting Member
Bill is a founding member
 has been a member for 10 years
Bill owns a Planet Eclipse Ego
Quote:
Originally Posted by LSU Foolsball 70 View Post
What is the stock LPR setting for the CSL with I guess a LP poppit I have a Dart kit installed.


Thanks
1 turn in from flush.
__________________
WWW.PAINTBALLSHOWCASE.COM

Certified NorthEast Eclipse Technician/Warranty Center!

Used Gun thread: EGO8s, DMs, Shockers, and more...
Bill is offline  
Old 11-06-2012, 03:31 AM #1161
Bill
Paintball Showcase
 
Bill's Avatar
 
Join Date: Nov 2001
Location: Paintball Showcase
Annual Supporting Member
Bill is a Supporting Member
Bill is a founding member
 has been a member for 10 years
Bill owns a Planet Eclipse Ego
Quote:
Originally Posted by wildspinx View Post
Is there anyway to buy a replacement solenoid for an 06 ego, or way to fix it? Or am I going to have to sell a perfectly good gun because I cannot find a solenoid...
You can easily mount an EGO7/8 solenoid and manifold in your marker. You just need to turn the dwell to 13.
__________________
WWW.PAINTBALLSHOWCASE.COM

Certified NorthEast Eclipse Technician/Warranty Center!

Used Gun thread: EGO8s, DMs, Shockers, and more...
Bill is offline  
Old 11-06-2012, 09:03 AM #1162
Jose1998
 
 
Jose1998's Avatar
 
Join Date: Apr 2011
Location: Downey, CA.
Jose1998 owns a Planet Eclipse Geo
Jose1998 posts videos on PbNation
Jose1998 plays in the APPA D4 division
Jose1998 has achieved Level 3 in PbNation Pursuit
Hey bill, I just bought the new dart kit for my ego 11. I used it for 2 weeks then it started leaking from the valve. I changed all my orings on it but it still kept leaking. I switched it to my stock valve and bolt and everything worked fine. What could it be?
__________________
EXTREME PROS FACTORY TEAM
Jose1998 is offline  
Old 11-06-2012, 02:00 PM #1163
FalconPunchKid
St. Louis Hustle
 
FalconPunchKid's Avatar
 
Join Date: Aug 2012
Location: St. Louis
Annual Supporting Member
FalconPunchKid is BST Legit
FalconPunchKid is playing at Living Legends VII
FalconPunchKid owns a Planet Eclipse Lv1
FalconPunchKid plays in the APPA D4 division
FalconPunchKid supports DLX Technology
FalconPunchKid supports Empire
Quote:
Originally Posted by Bill View Post
The screen on a 10 is interchangeable. You can get them from any PE tech

They usually go bad from excess oil or grease contact.
Thanks! I just ordered a new one yesterday. I think it might of actually been you I ordered it from. If you remember saying a guy sounded like he was 14?
__________________
⚓US NAVY⚓
They call me "DOC"
PROUD LUXE OWNER

Anthony Antle
FalconPunchKid is offline  
Old 11-06-2012, 04:31 PM #1164
Bill
Paintball Showcase
 
Bill's Avatar
 
Join Date: Nov 2001
Location: Paintball Showcase
Annual Supporting Member
Bill is a Supporting Member
Bill is a founding member
 has been a member for 10 years
Bill owns a Planet Eclipse Ego
Quote:
Originally Posted by Jose1998 View Post
Hey bill, I just bought the new dart kit for my ego 11. I used it for 2 weeks then it started leaking from the valve. I changed all my orings on it but it still kept leaking. I switched it to my stock valve and bolt and everything worked fine. What could it be?
Sounds like the front valve face could be slightly nicked. I would recommend sending it and the valve poppet into PE RI for inspection and warranty.
__________________
WWW.PAINTBALLSHOWCASE.COM

Certified NorthEast Eclipse Technician/Warranty Center!

Used Gun thread: EGO8s, DMs, Shockers, and more...
Bill is offline  
Old 11-06-2012, 04:31 PM #1165
Bill
Paintball Showcase
 
Bill's Avatar
 
Join Date: Nov 2001
Location: Paintball Showcase
Annual Supporting Member
Bill is a Supporting Member
Bill is a founding member
 has been a member for 10 years
Bill owns a Planet Eclipse Ego
Quote:
Originally Posted by FalconPunchKid View Post
Thanks! I just ordered a new one yesterday. I think it might of actually been you I ordered it from. If you remember saying a guy sounded like he was 14?
No, wasnt me or my company. I didnt have an order for a screen in the last few days.
__________________
WWW.PAINTBALLSHOWCASE.COM

Certified NorthEast Eclipse Technician/Warranty Center!

Used Gun thread: EGO8s, DMs, Shockers, and more...
Bill is offline  
Old 11-06-2012, 07:48 PM #1166
deadly*
⊙▃⊙
 
deadly*'s Avatar
 
Join Date: Jul 2007
Location: West Covina, CA
deadly* supports Team VICIOUS
deadly* supports Pev's Paintball
deadly* is one of the top 500 posters on PbNation
deadly* is Boss
my ego won't shoot below 350 fps.


clean the regulator?
__________________
Simple mantra.
deadly* is online now  
Old 11-07-2012, 03:34 AM #1167
Bill
Paintball Showcase
 
Bill's Avatar
 
Join Date: Nov 2001
Location: Paintball Showcase
Annual Supporting Member
Bill is a Supporting Member
Bill is a founding member
 has been a member for 10 years
Bill owns a Planet Eclipse Ego
What year EGO? It is most likely your regulator seat being bad.
__________________
WWW.PAINTBALLSHOWCASE.COM

Certified NorthEast Eclipse Technician/Warranty Center!

Used Gun thread: EGO8s, DMs, Shockers, and more...
Bill is offline  
Old 11-07-2012, 12:42 PM #1168
deadly*
⊙▃⊙
 
deadly*'s Avatar
 
Join Date: Jul 2007
Location: West Covina, CA
deadly* supports Team VICIOUS
deadly* supports Pev's Paintball
deadly* is one of the top 500 posters on PbNation
deadly* is Boss
its an Ego 10
__________________
Simple mantra.
deadly* is online now  
Old 11-08-2012, 03:05 AM #1169
Bill
Paintball Showcase
 
Bill's Avatar
 
Join Date: Nov 2001
Location: Paintball Showcase
Annual Supporting Member
Bill is a Supporting Member
Bill is a founding member
 has been a member for 10 years
Bill owns a Planet Eclipse Ego
Check the HPR Piston seal. If cracked or missing change out the piston.
Same goes for the LPR Piston seal.
Is your dwell stock? Try turning it down 1ms.
__________________
WWW.PAINTBALLSHOWCASE.COM

Certified NorthEast Eclipse Technician/Warranty Center!

Used Gun thread: EGO8s, DMs, Shockers, and more...
Bill is offline  
Old 11-10-2012, 05:36 PM #1170
MarceloBassani
 
 
MarceloBassani's Avatar
 
Join Date: Dec 2008
Location: Niterói - RJ - Brazil
MarceloBassani owns a Planet Eclipse Ego
Hi Bill, I just bought a CSL with almost a year of use and I would like to know which setting is indicated for the dwell, fsd comp and fsd dly?
__________________
NITERÓI STORM PAINTBALL TEAM - BRAZIL
MarceloBassani is offline  
Old 11-10-2012, 09:40 PM #1171
JRizEJ6
 
 
JRizEJ6's Avatar
 
Join Date: Apr 2008
JRizEJ6 owns a Planet Eclipse Geo
hi, recently my ego11 has been very inconsistent and constantly breaking paint. my chrono #s are up and down between 210-260, and im constantly breaking (barrel break) paint. ive reset the board back to factory settings, set the lpr and hpr to recommended factory specs, changed all hpr o-rings, and checked detents with no results. noid settings are 4-7. it has about 18 cases through it however i have not yet serviced the noid since buying it brand new. any suggestions?
JRizEJ6 is offline  
Old 11-11-2012, 01:25 PM #1172
Uko
 
 
Join Date: May 2010
hi,

My ego 08 does not fire in ramping. The battery is new, the dwell is 12.5 and the board is standard.

I put a video on how to shoot in ramping caps off:

http://www.youtube.com/watch?v=WZ9t5...ature=youtu.be

I hope you can help me
Uko is offline  
Old 11-11-2012, 02:24 PM #1173
coolz77
 
 
Join Date: Nov 2012
Hi. i own an EGO9 special edition Team avalanche. I have it for 3 years now and its a great gun but lately i got a small problem. When i gas up the gun or if i dont shoot it for a little amount of time (like 20-30 seconds) the first shot is weak like spitting the paint (almost like when u try and shoot it without a barrel) it just doesn't have enough power. After the first shot everything is ok and i can ramp normally. The battery is new and i tried it with different tanks just to make sure. I didn't change anything on the setting or anything else. any ideas??
coolz77 is offline  
Old 11-12-2012, 03:18 PM #1174
kjinxx2
 
 
Join Date: Oct 2012
Hello,

I recently purchased an Ego 08. It has no leaks but velocity caps around 245 or so - that is with the HPR screw as far out as possible. I stripped the gun, examined all o-rings, and everything appears to be intact. I'm not sure if it's a cold weather issue, or what. Any idea where to start?
kjinxx2 is offline  
Old 11-12-2012, 04:10 PM #1175
Uko
 
 
Join Date: May 2010
Quote:
Originally Posted by Uko View Post
hi,

My ego 08 does not fire in ramping. The battery is new, the dwell is 12.5 and the board is standard.

I put a video on how to shoot in ramping caps off:

http://www.youtube.com/watch?v=WZ9t5...ature=youtu.be

I hope you can help me
SOLVED. At the end was the CAP OFF ROF parameter that was too low.
Uko is offline  
Old 11-12-2012, 11:14 PM #1176
kingaaron
 
 
kingaaron's Avatar
 
Join Date: Oct 2006
Location: So Cal
kingaaron owns a Planet Eclipse Ego
kingaaron has achieved Level 1 in PbNation Pursuit
Hi Bill, please help.

Strange problem with an ego 6, when aired up the ram slowly moves forward then it starts to leak.

I remove the rammer and there's a ton of blue grease on it. I'm trying to figure out what makes the ram stay forward? Stuck solenoid clogged up by grease? (I know were only suppose to use oil on the rammer and this is a friends marker who thought it was ok to put grease on the rammer I scolded him!)

Solved by replacing both rammer o rings.

Last edited by kingaaron : 11-13-2012 at 10:27 PM. Reason: Solved.
kingaaron is offline  
Closed Thread


Thread Tools

Posting Rules
Forum Jump