Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 10-01-2012, 02:27 PM #1
OrangeLizard6
Can I have it?
 
OrangeLizard6's Avatar
 
Join Date: Feb 2011
OrangeLizard6 plays in the PSP
OrangeLizard6 is an NCPA player
OrangeLizard6 plays in the APPA D4 division
Geo+ problem. Would like some assistance.

Hokay. So, I have a Geo+ and when I went to shoot it, it was shooting like it was still in training. mode. I checked the settings and training mode was turned off. Then I replaced the battery with a brand new Duracell. Still didn't work. I replaced all the orings in the bolt, took the gun completely apart, cleaned, and lubed it. Put it back together and it still act's like it's in training mode. I went and reset all of the settings back to default and that didn't help. Looked up somewhere that the solenoid could be the problem so took it off cleaned the ports and the red gasket. I took out the solenoid spool and replaced the orange orings with new black orings. Put it all back together and it still does the same thing. I even went to the extent of putting a friends Geo solenoid that works fine in his gun in mine and still no difference. I am at a loss of what to do and would like some help. I'm headed to World Cup 2012 in a couple of weeks and didn't want to send it off somewhere to get it fixed, when I heard that there are PE techs there that could fix it. I was just curious if any of you have had this problem and fixed it on your own.

Thanks a lot.
__________________
I'm too legitimate to quitimate.
OrangeLizard6 is offline   Reply With Quote
Old 10-01-2012, 03:47 PM #2
p8ntshoota
Eclipse Tech Support
 
p8ntshoota's Avatar
 
Join Date: Jan 2003
Location: In a Tech Tent Somewhere
p8ntshoota is a Supporting Member
 has been a member for 10 years
p8ntshoota works for a Paintball manufacturer
p8ntshoota owns a Planet Eclipse Etha
Try changing your Back Check Ball...Make sure your Dwell is not too low...Make sure you are running a Fresh High Quality battery.
__________________
You broke it didn't you!

I Love that it takes longer to open a package for a repair on an Ego than it takes to actually fix the gun!

For the Love of Paintball....Use OILon the rammer!

If you THINK you're a Super Hero...You're NOT! SLIDE RIGHT!!!
p8ntshoota is offline   Reply With Quote
Old 10-01-2012, 04:41 PM #3
OrangeLizard6
Can I have it?
 
OrangeLizard6's Avatar
 
Join Date: Feb 2011
OrangeLizard6 plays in the PSP
OrangeLizard6 is an NCPA player
OrangeLizard6 plays in the APPA D4 division
Quote:
Originally Posted by p8ntshoota View Post
Make sure your Dwell is not too low...Make sure you are running a Fresh High Quality battery.
Quote:
Originally Posted by OrangeLizard6 View Post
I replaced the battery with a brand new Duracell. Still didn't work. ... I went and reset all of the settings back to default and that didn't help.
So just for grins, I looked at the Back Check Ball, cleaned it and where it fits in the solenoid. Still have the same problem.
__________________
I'm too legitimate to quitimate.
OrangeLizard6 is offline   Reply With Quote
Old 10-01-2012, 05:41 PM #4
FreeSpiritBaller
 
 
FreeSpiritBaller's Avatar
 
Join Date: Sep 2012
Location: ohio
FreeSpiritBaller owns a Planet Eclipse Geo
I have a geo that id be willing to send to you for cheap.. if you think you could use the internals... the gun works fine and shoots great. Let me know
__________________
One Day At A Time
FreeSpiritBaller is offline   Reply With Quote
Old 10-02-2012, 10:35 AM #5
C0ck3r_W0RR1OR
Dyin's for Fools!
 
C0ck3r_W0RR1OR's Avatar
 
Join Date: Aug 2008
Location: Port Moody, BC
Annual Supporting Member
C0ck3r_W0RR1OR owns a Planet Eclipse Geo
C0ck3r_W0RR1OR owns a Planet Eclipse Ego
Replace the back check ball, and replace the solenoid gasket.

But jeeh sounds wack. Definitely bring it to the Planet booth at World Cup.
C0ck3r_W0RR1OR is offline   Reply With Quote
Old 10-02-2012, 12:25 PM #6
p8ntshoota
Eclipse Tech Support
 
p8ntshoota's Avatar
 
Join Date: Jan 2003
Location: In a Tech Tent Somewhere
p8ntshoota is a Supporting Member
 has been a member for 10 years
p8ntshoota works for a Paintball manufacturer
p8ntshoota owns a Planet Eclipse Etha
Quote:
Originally Posted by OrangeLizard6 View Post
So just for grins, I looked at the Back Check Ball, cleaned it and where it fits in the solenoid. Still have the same problem.
When you pulled that Back Check Cap out...did the red ball simply fall out into your hand when you tipped the solenoid? Or did you have to pry it out with an alan key?

If the ball is too small...it can get stuck in the manifold and not allow the air to dump from the front of the bolt which will make it just go puff puff...

Next...change your O rings again...make double sure you are putting 14X2 NBR 70 O rings on both the upper tier of the bolt as well as on the prop shaft.

Make sure you put both #20 on the outside of the can.
__________________
You broke it didn't you!

I Love that it takes longer to open a package for a repair on an Ego than it takes to actually fix the gun!

For the Love of Paintball....Use OILon the rammer!

If you THINK you're a Super Hero...You're NOT! SLIDE RIGHT!!!
p8ntshoota is offline   Reply With Quote
Old 10-02-2012, 03:25 PM #7
OrangeLizard6
Can I have it?
 
OrangeLizard6's Avatar
 
Join Date: Feb 2011
OrangeLizard6 plays in the PSP
OrangeLizard6 is an NCPA player
OrangeLizard6 plays in the APPA D4 division
p8ntshoota - When I took it out I had to push it out from the other side. I looked it over and the ball didn't have any deformities or anything. I even made sure that the little brass cap had the oring on it. I replaced the orings and it doesn't even seem like air is getting to the bolt. The air seems to be coming out of the trigger frame where it meets the body, and where the trigger frame meets the regulator.
__________________
I'm too legitimate to quitimate.
OrangeLizard6 is offline   Reply With Quote
Old 10-03-2012, 02:45 PM #8
OrangeLizard6
Can I have it?
 
OrangeLizard6's Avatar
 
Join Date: Feb 2011
OrangeLizard6 plays in the PSP
OrangeLizard6 is an NCPA player
OrangeLizard6 plays in the APPA D4 division
Also I have another question. Anyone know what could cause all the air to come out of the spool port in the solenoid? The place between the two screws. I connected the wires and the reg back together without screwing the body and the trigger frame together to see the solenoid. When I aired it up and shot it, it makes sort of the sound like it would in training mode but all the air is coming out of the spool gap in the manifold.
__________________
I'm too legitimate to quitimate.
OrangeLizard6 is offline   Reply With Quote
Old 10-03-2012, 06:51 PM #9
X A N A T 0 S
Travis Dixon
 
X A N A T 0 S's Avatar
 
Join Date: May 2009
Location: 810 So Mich
Annual Supporting Member
X A N A T 0 S plays in the PSP
X A N A T 0 S plays in the APPA D1 division
That's the solenoid venting my man, it does it when you're actually shooting it too. Try your regulator, servicing the velocity adjustment screw assembly, and the outter body orings as well as the piston. Did some weird stuff with my 2.0 I had.
__________________
Chicago INFAMOUS D1x 3rd Place WC2013
-Cru Paintball-

Like New Guns Sale! Custom Vanquishes! Rare G6rs, VX Clones, DARK EDITION Ego
X A N A T 0 S is online now   Reply With Quote
Old 10-15-2012, 06:31 PM #10
Ba_KiDz
 
 
Ba_KiDz's Avatar
 
Join Date: Aug 2004
Location: Cincinnati
Ba_KiDz plays in the PSP
Ba_KiDz owns a Planet Eclipse Geo
Ba_KiDz plays in the APPA D3 division
Ba_KiDz has achieved Level 1 in PbNation Pursuit
Ba_KiDz has achieved Level 2 in PbNation Pursuit
what does it mean if the ball just rolls out?
__________________
FUSE

Proudly Sponsored by:
Cabin Creek Paintball
Sandana
GI Sportz
OG NYX Jersey
Ba_KiDz is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump