Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 04-17-2012, 01:56 PM #64
Evilson
 
 
Join Date: Aug 2011
same problem

ok i got a 2.1 shooting when it degas, put it another regulator from another 2.1 and did the same, put it back the regulator, now i dunno why i have 2 geo 2.1 firing when it degas...
Evilson is offline   Reply With Quote
Old 04-17-2012, 04:14 PM #65
Uziel Gal
It's not a Geo2, honest..
 
Uziel Gal's Avatar
 
Join Date: Mar 2004
Location: London, UK
Uziel Gal donated to help Peyton Trent
Uziel Gal owns a Planet Eclipse Geo
Uziel Gal owns a Planet Eclipse Ego
Uziel Gal supports our troops
Unlike the Geo and Geo2, the Geo2.1 does not have the PCV mounted in the reg swivel collar. The PCV is mounted in the body, above the reg, instead. As such, switching regs will have no effect, as the problem remains in the body of the marker, rather than following the reg. You need to remove the plug that holds the PCV in place above the reg, clean the PCV, the plug and the cavity that the PCV sits in, and see if that resolves the issue.
Uziel Gal is offline   Reply With Quote
Old 05-05-2012, 04:59 PM #66
Evilson
 
 
Join Date: Aug 2011
Quote:
Originally Posted by Uziel Gal View Post
Unlike the Geo and Geo2, the Geo2.1 does not have the PCV mounted in the reg swivel collar. The PCV is mounted in the body, above the reg, instead. As such, switching regs will have no effect, as the problem remains in the body of the marker, rather than following the reg. You need to remove the plug that holds the PCV in place above the reg, clean the PCV, the plug and the cavity that the PCV sits in, and see if that resolves the issue.
could u please put pictures where the PCV are in the 2.1
thanks
__________________
G6r Dust Pink/black
Geo 2.1 Blue/green
Dm11 Inked
http://www.pbnation.com/showthread.php?t=3795179
Evilson is offline   Reply With Quote
Old 05-05-2012, 05:53 PM #67
Uziel Gal
It's not a Geo2, honest..
 
Uziel Gal's Avatar
 
Join Date: Mar 2004
Location: London, UK
Uziel Gal donated to help Peyton Trent
Uziel Gal owns a Planet Eclipse Geo
Uziel Gal owns a Planet Eclipse Ego
Uziel Gal supports our troops
I don't have a Geo2.1 personally, and so cannot take pictures of the PCV I'm afraid.

Quite simply though, you unscrew the reg from the marker, and the PCV is inside the threaded stub that the reg was screwed on to.
Uziel Gal is offline   Reply With Quote
Old 05-06-2012, 02:50 PM #68
Farred
 
 
Farred's Avatar
 
Join Date: Feb 2011
Location: Ramstein AB
Farred owns a Planet Eclipse Geo
Farred has achieved Level 1 in PbNation Pursuit
Farred has achieved Level 2 in PbNation Pursuit



i have a geo2 with the pcv in the body. here is the picture.
Farred is offline   Reply With Quote
Old 05-07-2012, 05:44 AM #69
Uziel Gal
It's not a Geo2, honest..
 
Uziel Gal's Avatar
 
Join Date: Mar 2004
Location: London, UK
Uziel Gal donated to help Peyton Trent
Uziel Gal owns a Planet Eclipse Geo
Uziel Gal owns a Planet Eclipse Ego
Uziel Gal supports our troops
^^^
Thanks.
Uziel Gal is offline   Reply With Quote
Old 05-07-2012, 10:28 AM #70
Evilson
 
 
Join Date: Aug 2011
Thanks!
__________________
G6r Dust Pink/black
Geo 2.1 Blue/green
Dm11 Inked
http://www.pbnation.com/showthread.php?t=3795179
Evilson is offline   Reply With Quote
Old 08-29-2012, 06:07 PM #71
1stplayed98
 
 
1stplayed98's Avatar
 
Join Date: Aug 2012
1stplayed98 owns a Planet Eclipse Geo
I'm currently experiencing this issue. I have made sure the PCV is in place, and tried installing the original fitting with pcv, and I still have bolt movement during degassing the marker. Its not a full shot but bolt does move to the full forward position with a small release of air. I believe this may be caused by my ASA venting the pressure to quickly. I swapped out the stock ASA for a BL Cam drive with drop forward (blasphemy I know). I have tested with and without the PCV and it is undoubtedly needed, but does not completely stop the discharge issue.

Would changing the ASA also allow the pressure to vent out to quickly to allow the PCV to be fully functional?
__________________
"Never had gun issues, until I bought an electro"
1stplayed98 is offline   Reply With Quote
Old 08-29-2012, 06:35 PM #72
jdpower
A.O.Y.T
 
jdpower's Avatar
 
Join Date: Oct 2005
Location: RI
jdpower owns a Planet Eclipse Geo
jdpower plays in the APPA D4 division
I had the same issue on my Geo 2.1. PE tech's at the NPPL DC event fixed it by changing out the small spring behind the PCV. Hope this helps.
__________________
jdpower is offline   Reply With Quote
Old 08-29-2012, 07:02 PM #73
1stplayed98
 
 
1stplayed98's Avatar
 
Join Date: Aug 2012
1stplayed98 owns a Planet Eclipse Geo
Unfortunately I'm using a Geo+, PCV is in the macro line fitting.
__________________
"Never had gun issues, until I bought an electro"
1stplayed98 is offline   Reply With Quote
Old 10-11-2012, 03:01 PM #74
grubb
 
 
grubb's Avatar
 
Join Date: Nov 2008
Location: Malaysia
grubb owns a Planet Eclipse Ego
grubb plays in the APPA D3 division
I am reposting in this thread. Also posted on the main board.

I have a GEO 2.1. Recently, after having it for 11 months and it shooting perfectly and very efficient with air ( at least 8 pods on a 68/4500), I came across something weird.

When I degassed the gun the bolt popped into the forward position. Now I've seen this happen before on a GEO2 and on another 2.1 and usually what I would do is to readjust/clean the spring in the PCV and that would solve the issue. So I tried to do that with mine. When I opened the PCV assembly I found a cracked rubber bumper situated at the tip of the PCV.

So I thought ok, I just need to get a replacement rubber bumper. I went to my local store and asked for it and the PE certified level 3 tech guy didn't know what I was talking about. I hadn't brought my marker with me so I couldn't show him. So I asked him to open up one of the display markers to show it to him. And there was no bumper there. He checked some other customers markers that he was servicing also and this bumper was not present.

Does anyone know what I'm talking about? Do some Geo 2.1s come with this bumper and some don't or is there a foreign object that somehow got into my gun that fits perfectly on the tip of the pcv?



Uploaded with ImageShack.us

Would appreciate if anyone could solve this mystery for me.

Thanks
grubb is online now   Reply With Quote
Old 10-11-2012, 07:48 PM #75
jdpower
A.O.Y.T
 
jdpower's Avatar
 
Join Date: Oct 2005
Location: RI
jdpower owns a Planet Eclipse Geo
jdpower plays in the APPA D4 division
Looks like a small o-ring. I do not have this so called bumper?
jdpower is offline   Reply With Quote
Old 10-10-2013, 03:50 PM #76
Just dat guy
O.O woah
 
Just dat guy's Avatar
 
Join Date: Jan 2013
Location: philly
Just dat guy owns a Planet Eclipse Geo
Just dat guy owns a Planet Eclipse Geo
Just dat guy plays in the APPA D5 division
Just dat guy has achieved Level 2 in PbNation Pursuit
Quote:
Originally Posted by 1stplayed98 View Post
Would changing the ASA also allow the pressure to vent out to quickly to allow the PCV to be fully functional?
^this. I switched my oops to a pops on my geo 1 and it vents out off the bolt causing it to shoot forward. any help is appreciated.
__________________
Hey! You with the face! And the Nose! And the Mouth! And the Eyes! I KNOW YOU.
***The reason we help players that are new to the sport is so that they continue to play the sport***
LVP SOUTH
Axes are best left to chopping wood.
Sofa Kingdom
Just dat guy is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump