Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 09-15-2012, 03:23 PM #1
ajmort00
 
 
ajmort00's Avatar
 
Join Date: Jan 2005
Location: Danville, KY
ajmort00 owns a Planet Eclipse Etek
So one of my mags won't seal when I put a fresh 12 gram in it. Any clues how to fix it?

Thx

Last edited by ajmort00 : 09-15-2012 at 04:20 PM.
ajmort00 is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 09-17-2012, 02:01 AM #2
Suppoko
 
 
Suppoko's Avatar
 
Join Date: Oct 2011
Location: Lincoln Park, MI.
Suppoko owns a Planet Eclipse Etek
Suppoko has achieved Level 2 in PbNation Pursuit
try putting a bit of oil on the black part of the clip the pin that punctures the 12 gram slides into. That usually fixes it
__________________
Stuff I am looking for

07PMR
Suppoko is offline   Reply With Quote
Old 09-19-2012, 09:03 PM #3
ajmort00
 
 
ajmort00's Avatar
 
Join Date: Jan 2005
Location: Danville, KY
ajmort00 owns a Planet Eclipse Etek
Ok. Tried that. No luck. Any other ideas?

Thx
ajmort00 is offline   Reply With Quote
Old 09-23-2012, 08:40 PM #4
thengthing
Pistols Only
 
thengthing's Avatar
 
Join Date: Apr 2011
Location: Boston, MA
thengthing has achieved Level 1 in PbNation Pursuit
First check the part circled in blue. If it's stuck or isn't popping up when you pressurize the mag, air could leak. Try using an allen wrench to gently nudge it to make sure it's in place. If that doesn't work, take a look at the O-rings highlighted in green to make sure they aren't broken.


Last edited by thengthing : 09-23-2012 at 08:47 PM. Reason: Better Pic
thengthing is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump