Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 08-04-2012, 03:10 PM #1
StuSidekick
 
 
Join Date: May 2009
Annual Supporting Member
StuSidekick owns a Planet Eclipse Geo
Tiberius 8.1 and Magazine Problem

The problem is that the magazine won't lock in place.

Stops at about 1/4 of an inch before locking in place.

I am guessing at 2 possibilities, but not sure:

1. the magazine is being blocked from locking in place by the push rod of the trigger group

2. the ball retainer pin of the magazine does not slide when magazine is inserted.
StuSidekick is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 08-04-2012, 03:48 PM #2
NoX13
WARNING: I Do Dumb ****!
 
NoX13's Avatar
 
Join Date: Jun 2005
Location: 18974
NoX13 has achieved Level 4 in PbNation Pursuit
NoX13 has achieved Level 5 in PbNation Pursuit
NoX13 is Legendary
did you buy them both together?

possible the mag is an older one not compatible with the t8.1?
__________________
I shot the Sheriff,The Deputy And the Ref.. But we all knew the Ref had it coming.

My drinking team has a paintball problem.

**** you, **** you, Youre Cool, **** YOU!,

Tiberius T9 Package
http://www.pbnation.com/showthread.php?t=4436345
NoX13 is offline   Reply With Quote
Old 08-04-2012, 03:52 PM #3
StuSidekick
 
 
Join Date: May 2009
Annual Supporting Member
StuSidekick owns a Planet Eclipse Geo
That is a possibility.

It was acquired in a trade. Was working for a day. Then problem appeared after cleaning since paint was in the trigger area.
StuSidekick is offline   Reply With Quote
Old 08-04-2012, 11:33 PM #4
NoX13
WARNING: I Do Dumb ****!
 
NoX13's Avatar
 
Join Date: Jun 2005
Location: 18974
NoX13 has achieved Level 4 in PbNation Pursuit
NoX13 has achieved Level 5 in PbNation Pursuit
NoX13 is Legendary
if you have already taken the marker apart, then put it back together.. you want to make sure the bolt is pushed forward before putting back together.

Not sure if that could be the cause or not but worth a check.
__________________
I shot the Sheriff,The Deputy And the Ref.. But we all knew the Ref had it coming.

My drinking team has a paintball problem.

**** you, **** you, Youre Cool, **** YOU!,

Tiberius T9 Package
http://www.pbnation.com/showthread.php?t=4436345
NoX13 is offline   Reply With Quote
Old 03-30-2013, 10:21 PM #5
fullbore
 
 
Join Date: Mar 2013
Came across this old thread as I was having the same issue with a brand new T8.1 where, for no explicable reason, the magazine would suddenly not fully engage with the magazine release.

Therefore I'm posting what I discovered in case anyone else is having the same issues.

The problem with my T8.1 was that the mag ball retainer pin, and mag ball retainer spring located just above the follower suddenly became too stiff on BOTH magazines at the same time.

I'm not sure but I think this bar pushes up against the ammo release fork as you insert the mag and then snaps into place. However, when it is not lubed properly it won't move and snap in place.

The solution is to run it wet and make sure the teeny spring, pin, and the guide in which the pin slides is lubed.

Now, I should have used a silicon based hobby lube (like those used for RC cars) because petroleum products are very bad for rubber o-rings, seals, and makes plastics fragile. But I only had some Corrosion X CLP gun lube on hand (since I shoot real steel and bought the T8.1 to be able to practice indoors). I sprayed the mag ball retainer pin and spring, loosened it up by moving the pin back and forth a few times and the mag now snaps in place without a problem.

Hope this somes in handy to the next guy looking for the solution to the problem of why the T8.1 mag suddenly doesn't snap into the mag well.
fullbore is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump