Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 04-10-2011, 08:36 AM #1
AJolliff
R doz my balls on ur fac?
 
AJolliff's Avatar
 
Join Date: Jul 2009
Location: where I am
might be a simple fix help please

So I got an old school quest in a trade and first I went to shoot it and insane bolt stick, so I replaced the o-rings and more lube, fixed the problem.

Now I go to shoot it and it wont even cycle unless the lpr is around 100-110 psi and then its only 3 consecutive shots and I have to wait for the lpr to recharge and if its set to 70-85 psi it wont cycle at all. I did notice it has the lpr mod hole but if its turned down air just leaks out that hole constantly as well.

I've taken the lpr off a couple times to see if anything is backwards but everything is the right way too.
AJolliff is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 04-10-2011, 12:10 PM #2
Uziel Gal
It's not a Geo2, honest..
 
Uziel Gal's Avatar
 
Join Date: Mar 2004
Location: London, UK
Uziel Gal donated to help Peyton Trent
Uziel Gal owns a Planet Eclipse Geo
Uziel Gal owns a Planet Eclipse Ego
Uziel Gal supports our troops
In respect to the added vent hole leaking if the pressure adjuster is screwed out too far, sounds like the vent hole was drilled too close to the body.

With the spring pressure released, the piston will move closer to the adjuster screw, and it sounds like the o-ring on your piston is passing the hole, which then allows air to leak out of the hole.

Last edited by Uziel Gal : 04-10-2011 at 06:22 PM. Reason: Typo.
Uziel Gal is offline   Reply With Quote
Old 04-10-2011, 05:24 PM #3
AJolliff
R doz my balls on ur fac?
 
AJolliff's Avatar
 
Join Date: Jul 2009
Location: where I am
That does make a lot of sense would plugging and redrilling the whole fix the recharging issue as well?
AJolliff is offline   Reply With Quote
Old 04-10-2011, 06:25 PM #4
Uziel Gal
It's not a Geo2, honest..
 
Uziel Gal's Avatar
 
Join Date: Mar 2004
Location: London, UK
Uziel Gal donated to help Peyton Trent
Uziel Gal owns a Planet Eclipse Geo
Uziel Gal owns a Planet Eclipse Ego
Uziel Gal supports our troops
Your new bolt o-rings may need to wear in.

Does the LPR piston move freely? If not, you could try a slightly smaller o-ring.

Last edited by Uziel Gal : 04-11-2011 at 01:02 AM.
Uziel Gal is offline   Reply With Quote
Old 04-10-2011, 08:37 PM #5
AJolliff
R doz my balls on ur fac?
 
AJolliff's Avatar
 
Join Date: Jul 2009
Location: where I am
No free moving on any parts it sounds like it works perfectly just shooting the pressure drops completely
AJolliff is offline   Reply With Quote
Old 04-11-2011, 01:03 AM #6
Uziel Gal
It's not a Geo2, honest..
 
Uziel Gal's Avatar
 
Join Date: Mar 2004
Location: London, UK
Uziel Gal donated to help Peyton Trent
Uziel Gal owns a Planet Eclipse Geo
Uziel Gal owns a Planet Eclipse Ego
Uziel Gal supports our troops
The only reasons I could imagine for poor re-charge of the regs is that the regs need servicing, or air flow from your air system is being restricted.
Uziel Gal is offline   Reply With Quote
Old 04-11-2011, 10:58 AM #7
AustStar2007
 
 
AustStar2007's Avatar
 
Join Date: Sep 2007
Location: *703*
Yeah I would rebuild the regs
AustStar2007 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump