Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 02-21-2011, 09:34 PM #1
XxcrazymanxX
 
 
XxcrazymanxX's Avatar
 
Join Date: May 2005
Location: Gainesville, Florida
XxcrazymanxX is a Supporting Member
XxcrazymanxX plays in the PSP
XxcrazymanxX is an NCPA player
Gen3 Empire Timmy Only shooting 220fps

Hey,

I recently picked up a custom milled gen3 empire 1 timmy. Guy I bought it from said worked great below 100psi and so far it seems to be 77-93psi. I have the new tadao usb oled board installed and a cp reg, along with multiple less important upgrades.

My gun only shoots 200-220fps and I cannot seem to shoot any higher. Ramping and everything else works perfectly.

I have played with my dwell from 8.5ms to 22.0ms. When I put dwell at 6.0ms, the gun wont fire and also at 24.0 ms. But between 8.5 and 22, there is no difference in velocity. While also adjusting cp reg.

Should I just disassemble my marker, clean, and relube everything? or is there something else that I'm missing?

Thanks,
John
__________________
IrishMafia
Redline
R.I.P. Ozmosis
Central Florida Paintball
XxcrazymanxX is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 02-21-2011, 09:49 PM #2
AustinHembo
`~`
 
AustinHembo's Avatar
 
Join Date: Oct 2009
AustinHembo plays in the PSP
AustinHembo is reppin' sidebar 4 life
AustinHembo plays in the APPA D4 division
Replace the rear ram o-ring first thing, and set your dwell and pressures to stock.

One question, are you using an eigenram with the empire poppet? I had an experience with using both those parts in my empire1 and not being able to achieve velocity...they just didn't like each other. I switched out the ram with a shocktech ram and it worked like a charm.
__________________
AustinHembo is offline   Reply With Quote
Old 02-22-2011, 01:38 AM #3
‹GOD›
PMGWC Council
 
‹GOD›'s Avatar
 
Join Date: Dec 2006
Location: A box.
‹GOD› helped look for balloons
‹GOD› is playing at Living Legends III
‹GOD› owns a Planet Eclipse Ego
Replace your battery.
Replace the rear ram o-ring and lube it with dow55.
Reset your regs.
Set your dwell to 9ms and your LPR to ~75psi.
__________________
Ironmen DM6 FS/T
Outkast Pump FS/T
Copper/Black 2K5 Intimidator FS/T
OLD FEEDBACK
"Originally posted by Gordofski: you can trust GOD though"
‹GOD› is offline   Reply With Quote
Old 02-22-2011, 06:58 AM #4
lopez17
Valar Morghulis
 
lopez17's Avatar
 
Join Date: Feb 2003
Location: Stone Ridge, VA
Annual Supporting Member
lopez17 is a Moderator
lopez17 is a Supporting Member
lopez17 is playing at Living Legends VII
lopez17 supports Pev's Paintball
lopez17 is one of the top 250 posters on PbNation
lopez17 is Immortal
If it's still not achieving velocity after doing what was instructed in the previous two posts, find another HPR and remove the CP. See if it works with a different regulator.
__________________
_____________________________
PEV'S PAINTBALL

lopez17 is offline   Reply With Quote
Old 02-22-2011, 04:40 PM #5
Lurker27
Engineering the Future
 
Lurker27's Avatar
 
Join Date: Jun 2003
Annual Supporting Member
Lurker27 is a Supporting Member
 has been a member for 10 years
Lurker27 posts videos on PbNation
Lurker27 has been published on the PbNation Youtube Channel
Quote:
Originally Posted by AustinHembo View Post
Replace the rear ram o-ring first thing, and set your dwell and pressures to stock.

One question, are you using an eigenram with the empire poppet? I had an experience with using both those parts in my empire1 and not being able to achieve velocity...they just didn't like each other. I switched out the ram with a shocktech ram and it worked like a charm.
This is due to the larger diameter cupseal of the empire poppet. Switching to an alias or vice poppet/cupseal is a bigtime upgrade.
__________________
World's Best Hard-Parts Upgrades!
EigenBarrels, Mini, AXE, Intimidators, DM, Shocker
Lurker27 is online now   Reply With Quote
Old 02-22-2011, 09:15 PM #6
XxcrazymanxX
 
 
XxcrazymanxX's Avatar
 
Join Date: May 2005
Location: Gainesville, Florida
XxcrazymanxX is a Supporting Member
XxcrazymanxX plays in the PSP
XxcrazymanxX is an NCPA player
Thanks for the advice everyone!

I will try these out as soon as I have time and let you guys know if it works. Btw, where is a good place to get timmy orings for a good price?
__________________
IrishMafia
Redline
R.I.P. Ozmosis
Central Florida Paintball
XxcrazymanxX is offline   Reply With Quote
Old 02-23-2011, 02:07 AM #7
BELOWZERO
2JZGTE POWERED
 
BELOWZERO's Avatar
 
Join Date: Sep 2006
Location: *317*
Annual Supporting Member
BELOWZERO is playing at Living Legends V
BELOWZERO is playing at Living Legends VI
BELOWZERO owns a Planet Eclipse SLS
BELOWZERO supports Team VICIOUS
BELOWZERO plays in the APPA D4 division
BELOWZERO is Legendary
BELOWZERO is Boss
http://www.mcmaster.com/#o-rings/=b5kj3s

or

http://www.oringmonkey.com/index.php?cPath=1_17
__________________
MIDWEST Royalty Sponsored by Cliff Edge Paintball

MUST STOP GUN BEING A GUN WHORE
FOR ALL YOUR BOBLONG NEEDS PM TIM2THOUSAND4
Field of Dreams
900-999-999
BELOWZERO is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump