Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 12-14-2010, 05:43 PM #1
Zyras
 
 
Join Date: Dec 2010
Question Blast from the past

New to here so feel free to push me in the right directions.

Was given a mongoose by a mate (Currently running an sp-8, 98 long very custom, a-5 customed, RAP4 Deagle RAM, TM-15)

Played with it last sunday, very nice marker apart from a few problems i've encountered that i would like some help on if possible:

1. It kicks like hell, screws are loosening all over the place.
2. The air usage is horrendous, i got 4x180 pots & a 220 hopper fom a 2.5k fill in a 68cu Hpa tank.
3. Seems to be breaking a few balls on the hammer.

Thanks in advance guys 'n' gals.

Meant to say:

Marker running at 275fps stable, paintballs being used by all players, very few breaks by anyone. Ran 300 rounds through my sp-8 at 12bps with no breaks whatsoever.

Last edited by Zyras : 12-14-2010 at 05:46 PM. Reason: Tech specs update
Zyras is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 12-29-2010, 02:58 PM #2
The Inflicted
.detcilfnI ehT
 
The Inflicted's Avatar
 
Join Date: Jan 2002
Location: Chattanooga, TN
Sounds like the spring balances are off. The previous user may have made some improper spring swaps using a spyder-compatible spring kit. If you bought another spyder spring kit (~$9) you should be able to play around with the balances and find a combination of valve and hammer springs that work better.
The Inflicted is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump