Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 12-04-2010, 08:03 PM #1
seanhockey13 (Banned)
 
 
Join Date: Sep 2009
Location: Burnsville, Minnesota
seanhockey13 plays in the PSP
seanhockey13 owns a Planet Eclipse Geo
seanhockey13 supports Team VICIOUS
seanhockey13 plays in the APPA D4 division
Geo 2 prob

Hey guys I just finished a tounry today and while playing there was 2 times when i start to chop like hell!! it sounded like the bolt was cycling fully. I then cleaned and relubed it and about 7 games later it happened again. Its like it makes the noise of it trying to shoot but the bolt didnt cycle or even go forward. Any suggestions or should i just keep cleaning and relubing it.
seanhockey13 is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 12-04-2010, 10:59 PM #2
Rockyboarder
So Long Gay boys....
 
Rockyboarder's Avatar
 
Join Date: Sep 2005
Location: San Diego
Rockyboarder owns a Planet Eclipse Geo
Sounds like you need some relubing or different lubes. Maybe even up the dwell a bit as the bolt doesn't sound like it's reliably cycling completely.
Rockyboarder is offline   Reply With Quote
Old 12-04-2010, 11:40 PM #3
dvsRaveR
 
 
Join Date: Mar 2010
Location: San Diego, CA
dvsRaveR owns a Planet Eclipse Geo
i had the same thing happen to me. I just kept cleaning it and relubing it when it happened. I don't know why it does what it does. All my settings are all stock.
dvsRaveR is offline   Reply With Quote
Old 12-04-2010, 11:44 PM #4
seanhockey13 (Banned)
 
 
Join Date: Sep 2009
Location: Burnsville, Minnesota
seanhockey13 plays in the PSP
seanhockey13 owns a Planet Eclipse Geo
seanhockey13 supports Team VICIOUS
seanhockey13 plays in the APPA D4 division
ya same all my settings are stock and it got rather annoying when in the middle of a big point the gun goes to hell
seanhockey13 is offline   Reply With Quote
Old 12-04-2010, 11:48 PM #5
Rockyboarder
So Long Gay boys....
 
Rockyboarder's Avatar
 
Join Date: Sep 2005
Location: San Diego
Rockyboarder owns a Planet Eclipse Geo
Like I said bud, maybe up the dwell a half a millisecond.
Rockyboarder is offline   Reply With Quote
Old 12-04-2010, 11:54 PM #6
seanhockey13 (Banned)
 
 
Join Date: Sep 2009
Location: Burnsville, Minnesota
seanhockey13 plays in the PSP
seanhockey13 owns a Planet Eclipse Geo
seanhockey13 supports Team VICIOUS
seanhockey13 plays in the APPA D4 division
alright ill try that
seanhockey13 is offline   Reply With Quote
Old 12-05-2010, 03:54 AM #7
epik808
RED TURTLE MEDIA
 
epik808's Avatar
 
Join Date: Mar 2004
Location: Oahu, Hawaii
 has been a member for 10 years
epik808 posts videos on PbNation
epik808 has been published on the PbNation Youtube Channel
check your detents. sometimes when you de-gas your gun the bolt moves all the way forward and stays there be sure to check that and push bolt back to extend the life of the detents
__________________

OLD FEEDBACK
+33 old feedback +35 new=68 100%positive
HAWAII PAINTBALL VIDEOS
epik808 is offline   Reply With Quote
Old 12-05-2010, 09:16 AM #8
Uziel Gal
It's not a Geo2, honest..
 
Uziel Gal's Avatar
 
Join Date: Mar 2004
Location: London, UK
Uziel Gal donated to help Peyton Trent
Uziel Gal owns a Planet Eclipse Geo
Uziel Gal owns a Planet Eclipse Ego
Uziel Gal supports our troops
Don't know how the temperature is where you are, but cold weather can play havoc with paint quality and fagility, so it could just be the paint at fault. When the paint is fragile - be it due to weather conditions or for any other reason - having your loader set for high speed and/or high tension can lead to paint breaking inside the loader, which can then lead to misfeeds causing the marker to chop.
Uziel Gal is offline   Reply With Quote
Old 12-07-2010, 11:42 AM #9
chuchutrain
 
 
chuchutrain's Avatar
 
Join Date: Jul 2009
Location: Texas
Yeah I played with my Geo 2 this weekend and a could times it would chop for no reason. Stranger than that it would almost freeze up and not respond for a trigger pull. I assume its because we were playing in the mid 40s. It shoots great. Just sticks from time to time.
chuchutrain is offline   Reply With Quote
Old 12-07-2010, 11:50 AM #10
petedaddy
Mission Accomplished!
 
petedaddy's Avatar
 
Join Date: Apr 2008
Location: Dirty Jerz
I have to say, I played this weeknd in very cold weather....maybe about 36-40 degrees. Zero chops....
petedaddy is offline   Reply With Quote
Old 12-08-2010, 07:30 AM #11
megabuck 14
 
 
megabuck 14's Avatar
 
Join Date: May 2010
Location: Waller, TX
megabuck 14 plays in the PSP
megabuck 14 owns a Planet Eclipse Geo
megabuck 14 posts videos on PbNation
megabuck 14 plays in the APPA D4 division
Just make sure that when its colder you don't put as much lube on the bolt because it will tend to get sludgy. But on the other hand when its cold, you have to make sure that your o-rings don't dry out! So keep an eye on ur bolt in cold weather.
__________________
BRUTAL BEAT DOWN!
megabuck 14 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump