Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 07-14-2010, 06:27 PM #1
BANANA!!!
seven shooter
 
BANANA!!!'s Avatar
 
Join Date: Aug 2004
Location: West Allis/MKE,Wisconsin
 has been a member for 10 years
Gauges not working after hydro

I recently sent in my Nitroduck X-Stream adjustable tank for hydro and when I received it, the gauges were not working. The output gauge is stuck below 400psi and the gauge that shows pressure left won't go above 1500psi. There is fresh Teflon tape around the threads. Any possible solutions other than getting new gauges?
BANANA!!! is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 07-14-2010, 08:10 PM #2
Crazy-Jazz
 
 
Crazy-Jazz's Avatar
 
Join Date: May 2010
try unscrewing the gauges and then screwing them back on, if that doesn't work contact the company that did the hysdro and ask them about it.
__________________
Your comment was literally about as logical as "Clouds do not exist because Ronald McDonald has a fish sandwich".

"Originally posted by Iron__Man: dude, lose the 22 inch barrel. i wouldnt even tell people you owned it. personally it sounds like a case of overcompensation to me."
Crazy-Jazz is offline   Reply With Quote
Old 07-14-2010, 08:19 PM #3
BANANA!!!
seven shooter
 
BANANA!!!'s Avatar
 
Join Date: Aug 2004
Location: West Allis/MKE,Wisconsin
 has been a member for 10 years
I took a look at an older picture of my tank and saw that the gauges were swapped. I'll probably have to pick up a gauge for output pressure.
BANANA!!! is offline   Reply With Quote
Old 07-15-2010, 11:38 PM #4
JELCO PAINTBALL
 
 
Join Date: May 2009
Gauges are only 8 bucks. Pretty cheap fix if needed.
__________________
JELCO Paintball & Airsoft Supply

119 N Church St
P.O. Box 7
Gibson City, Illinois 60936
(217) 321-1818

Facebook Search - "JELCO Paintball Supply"
JELCO PAINTBALL is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump