Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 05-16-2010, 07:21 PM #1
SpyCo969
Northeast Pursuit
 
SpyCo969's Avatar
 
Join Date: May 2010
SpyCo969 owns a Planet Eclipse Geo
SpyCo969 owns a Planet Eclipse Ego
Huge drop-off after 1st ball?

Hey Guys~
I got a brand new Geo+ two weeks ago, the thing shot like a champ and then all of a sudden the balls just rolled out the barrel whenever i shot it, like it didn't have enough air to push them out the barrel so they just rolled out. I thought it was my bolt sticking, so i lubed it up and tried it again and it worked fine!
Then today, about 500 balls later it did the same thing on me, so naturally i thought it was the bolt again...well when i re-lubed it, i got the same result..balls would just roll out.
I took apart the entire gun, lubed everything again, still nothing.
Well i've figured out that if i turn on the gun, it shoots one ball completely fine..then after that 1st ball, the rest just roll out. If i turn it off and then back on, it shoots the next ball fine...but the one after= no such luck.
It seems to me like its a problem with one of the board settings? anyone have any ideas?
Any help is GREATLY appreciated!! I'm going nuts! for $895 the gun should be problem-free for longer than this!
__________________
NORTHEAST PURSUIT
Proudly Sponsored By:
Empire Paintball
Critical Paintball
Raza Paintball
SpyCo969 is offline   Reply With Quote
Old 05-16-2010, 07:37 PM #2
Speedballer844
Paypal Verified.
 
Speedballer844's Avatar
 
Join Date: Jun 2009
Location: New England
Speedballer844 is a Paintball photographer
Speedballer844 plays in the PSP
is it stock settings? dwell wise?
what kind of tank are you using?
NEW BATTERY? durecell energizer and such?
over lube? try wiping it all off then taking the smallest amount to every oring on the bolt beside for the top one on the bolt and just rubing it around so were you cant see anylube just haveing the orings wet.
^thats just and idea but with my geo the orings would just have to be wet to work fine with no problems EVER.
Speedballer844 is offline   Reply With Quote
Old 05-16-2010, 07:44 PM #3
SpyCo969
Northeast Pursuit
 
SpyCo969's Avatar
 
Join Date: May 2010
SpyCo969 owns a Planet Eclipse Geo
SpyCo969 owns a Planet Eclipse Ego
yup~ stock settings
I'm using a PMI 68/45
tried 2 different batteries, both new..same result
I've tried 3 different amounts of lube, nothing changed it :-/
Like i said, i think its something with the board but i didn't change anything as far as dwell/fsdo or anything like that
__________________
NORTHEAST PURSUIT
Proudly Sponsored By:
Empire Paintball
Critical Paintball
Raza Paintball
SpyCo969 is offline   Reply With Quote
Old 05-16-2010, 07:54 PM #4
okitoki
I have Upgrade'itis
 
okitoki's Avatar
 
Join Date: May 2008
Location: Perth, Australia
okitoki owns a Planet Eclipse Ego
okitoki has achieved Level 1 in PbNation Pursuit
okitoki has perfected Level 1 in PbNation Pursuit
okitoki has achieved Level 2 in PbNation Pursuit
okitoki has perfected Level 2 in PbNation Pursuit
Check your noid wire and see if there is any cut or crimps on it?
__________________
"Originally posted by msonic: Viagra is not supposed to be taken as a suppository..."
"Originally posted by x420psykoticx: "business casual" to me means a gold mini skirt and a see through haltertop"

okitoki is offline   Reply With Quote
Old 05-16-2010, 08:51 PM #5
spyder2005
 
 
spyder2005's Avatar
 
Join Date: Jun 2007
Location: murfreesboro, tn
take out the GST kit and push the bolt out the back of it. There is a o- ring inside that might need some lube....
__________________
Combat Geo2
Red and black Geo, Gr-2,GST,Sly carbon barrels.
spyder2005 is offline   Reply With Quote
Old 05-16-2010, 09:55 PM #6
Speedballer844
Paypal Verified.
 
Speedballer844's Avatar
 
Join Date: Jun 2009
Location: New England
Speedballer844 is a Paintball photographer
Speedballer844 plays in the PSP
lp or hp i no its stupid but if lp without the spring theres a chance and by new battery a NAME BRAND duracell or energizer? check for pinched wires like stated above also might want to lube the reg. it kinda sounds like you could use a noid repair(just put fresh gasket ball and spring all the small orings and the vent) that could possibly do the trick. hopefully uziel gal has something to say that anyones forgotten lol!
Speedballer844 is offline   Reply With Quote
Old 05-16-2010, 10:10 PM #7
xluben
Ben Johnson Photography
 
xluben's Avatar
 
Join Date: Mar 2007
Location: Minneapolis, MN
Annual Supporting Member
xluben is a Paintball photographer
xluben plays in the PSP
xluben owns a Planet Eclipse Geo
xluben posts videos on PbNation
xluben owns a Planet Eclipse GSL
If turning it off and back one will get you another good shot, then it definitely sounds like an electronics problem. I would suspect the battery first and foremost. A brand new, name brand battery is a must.
xluben is offline   Reply With Quote
Old 05-17-2010, 01:54 AM #8
Uziel Gal
It's not a Geo2, honest..
 
Uziel Gal's Avatar
 
Join Date: Mar 2004
Location: London, UK
Uziel Gal donated to help Peyton Trent
Uziel Gal owns a Planet Eclipse Geo
Uziel Gal owns a Planet Eclipse Ego
Uziel Gal supports our troops
JJust a couple of quick things to start off with.

Is your dwell set to 12.5ms or 14.5ms? If it is set to 12.5ms, try increasing to 14.5ms.

Are you screwing the ASA knob in all the way? If not try that. Conversely, if you are screwing the knob in all the way, try backing it out half a turn and see if that makes any difference.
Uziel Gal is offline   Reply With Quote
Old 05-17-2010, 01:38 PM #9
SpyCo969
Northeast Pursuit
 
SpyCo969's Avatar
 
Join Date: May 2010
SpyCo969 owns a Planet Eclipse Geo
SpyCo969 owns a Planet Eclipse Ego
Thank you all for your speedy responses! I'll give th dwell a look once I get home-- and I tried that ASA solution and still got the same result, I'm hoping it isn't a bad fill that keeps clogging the filter, although when I checked it the first time it seemed to be fine
__________________
NORTHEAST PURSUIT
Proudly Sponsored By:
Empire Paintball
Critical Paintball
Raza Paintball
SpyCo969 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump