Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 03-31-2010, 09:14 PM #1
todamax369
Dustin
 
todamax369's Avatar
 
Join Date: May 2008
Location: NY 845
todamax369 is BST Trusted
todamax369 is playing at Living Legends VII
todamax369 posts videos on PbNation
todamax369 is attending Decay of Nations VII
SLG Ball Jam

I have a problem with the ball jamming intermittenly on my slg. I've had the marker since new. It's only 8 months old and since then it's been jamming. Bought it from my local shop. Took it to them and they said there's nothing wrong with it that they can find. The marker is immaculate inside and out. Eyes are perfectly clean. Tried three different types of fresh new paint. Lubed it properly myself with hater. Checked detents and their fine. Hopper has fresh batteries and works flawlessly on my DM7. The bolt doesn't chop the ball. It just gets jammed in the breach. I don't know what else to check/do. Anybody ever have a similar problem or suggestions?
todamax369 is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 04-01-2010, 01:57 PM #2
dblk22vball
 
 
dblk22vball's Avatar
 
Join Date: Dec 2006
Location: Finland(use a world map)
Annual Supporting Member
dblk22vball supports our troops
So the ball will fully load into the breech, the bolt just cant push it out?

Or is the ball not falling into the breech all of the way?
__________________
I like old stuff.
dblk22vball is offline   Reply With Quote
Old 04-01-2010, 03:39 PM #3
protoslg843
 
 
protoslg843's Avatar
 
Join Date: Mar 2010
Location: chucktown
protoslg843 owns a Planet Eclipse Etek
same problem here bro. its a common SLG problem. Here what to do

1) Call DYE and get an RA#, ask for one and theyll tell u what it is if you dont know.
2) write down the RA#, then put it all over the box and mail it to do with a note of this issue

P.S. If they try to give you new detents instead of sending it in say no..... i said yes and it didnt work
protoslg843 is offline   Reply With Quote
Old 04-01-2010, 03:52 PM #4
dblk22vball
 
 
dblk22vball's Avatar
 
Join Date: Dec 2006
Location: Finland(use a world map)
Annual Supporting Member
dblk22vball supports our troops
Quote:
Originally Posted by protoslg843 View Post
same problem here bro. its a common SLG problem. Here what to do

1) Call DYE and get an RA#, ask for one and theyll tell u what it is if you dont know.
2) write down the RA#, then put it all over the box and mail it to do with a note of this issue

P.S. If they try to give you new detents instead of sending it in say no..... i said yes and it didnt work
probably not a bad idea. I had to send on in to have the breech reamed out since the body was milled wrong and was not big enough to even fit the bolt through it.
__________________
I like old stuff.
dblk22vball is offline   Reply With Quote
Old 04-01-2010, 04:38 PM #5
todamax369
Dustin
 
todamax369's Avatar
 
Join Date: May 2008
Location: NY 845
todamax369 is BST Trusted
todamax369 is playing at Living Legends VII
todamax369 posts videos on PbNation
todamax369 is attending Decay of Nations VII
Quote:
Originally Posted by dblk22vball View Post
So the ball will fully load into the breech, the bolt just cant push it out?

Or is the ball not falling into the breech all of the way?
The ball doesn't fall completely into the breach. The bolt literally "squeezes" the ball against the bottom part of the feedneck and then you just get clicking. Turn the eyes off and then you chop the ball.
todamax369 is offline   Reply With Quote
Old 04-01-2010, 04:39 PM #6
todamax369
Dustin
 
todamax369's Avatar
 
Join Date: May 2008
Location: NY 845
todamax369 is BST Trusted
todamax369 is playing at Living Legends VII
todamax369 posts videos on PbNation
todamax369 is attending Decay of Nations VII
Quote:
Originally Posted by protoslg843 View Post
same problem here bro. its a common SLG problem. Here what to do

1) Call DYE and get an RA#, ask for one and theyll tell u what it is if you dont know.
2) write down the RA#, then put it all over the box and mail it to do with a note of this issue

P.S. If they try to give you new detents instead of sending it in say no..... i said yes and it didnt work
Thanks for the idea. I'm at that point being I've tried everything else. I just never thought they would have made milling mistakes, or installed wrong bolt etc...
todamax369 is offline   Reply With Quote
Old 04-01-2010, 04:41 PM #7
todamax369
Dustin
 
todamax369's Avatar
 
Join Date: May 2008
Location: NY 845
todamax369 is BST Trusted
todamax369 is playing at Living Legends VII
todamax369 posts videos on PbNation
todamax369 is attending Decay of Nations VII
I was also thinking of trying a new bolt kit. I've heard of some protos being manufactured where the bolts were too small.
todamax369 is offline   Reply With Quote
Old 04-02-2010, 02:03 AM #8
protoslg843
 
 
protoslg843's Avatar
 
Join Date: Mar 2010
Location: chucktown
protoslg843 owns a Planet Eclipse Etek
oh i forgot.... when u send it in tell them to ream it.... its not that the bolts too small its the millings too small for the bolt and cause the bolt to push up and pinch the ball
protoslg843 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump