Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 04-01-2010, 10:48 AM #1
hot_box
 
 
Join Date: Oct 2007
Location: Rochester
tm7 problem

the bolt on my tm7 is not returning all the way back so it will not allow a ball to feed into the breach? this just started happening. anyone know what i can do?

thanks in advance
hot_box is offline   Reply With Quote
Old 04-01-2010, 10:59 AM #2
TheBoss33
 
 
TheBoss33's Avatar
 
Join Date: Dec 2002
Location: Waterloo, NY
TheBoss33 is a Supporting Member
 has been a member for 10 years
TheBoss33 is All In
TheBoss33 is All In
Have you taken it apart? Maybe the bolt spring not in properly or swollen o-rings. Do you have the stock bolt in it?

By the way, are you in Rochester, NY? Not too far from me.
TheBoss33 is offline   Reply With Quote
Old 04-09-2010, 11:59 PM #3
jcspball13
Tigers love pepper!
 
jcspball13's Avatar
 
Join Date: Feb 2009
Location: Delta, PA
Annual Supporting Member
jcspball13 plays in the USPL
jcspball13 supports Cereal Killerz 2
jcspball13 donated to help Peyton Trent
jcspball13 owns a Planet Eclipse Geo
jcspball13 supports Bob Gurnsey
jcspball13 plays in the APPA beginner division
It just needs to be Lubed up most likely. The TM& has the same internals as a mini, and if the mini gets too dry, it plain won't fire. Take the gun apart, clean it with rubbing alcohol, and lube it real good with either Dow33 or hater sauce, and put it back together. If that doesnt work, make sure your ball detentes aren't too tight, sometimes they can actually pinch the bolt.
__________________
Paintball, how I miss you!
jcspball13 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump