Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 02-22-2010, 08:32 PM #1
fatballer189
 
 
fatballer189's Avatar
 
Join Date: Sep 2007
Geo venting

So just picked up a used geo. It is venting from the noid area. Not sure if it is the gaskit or not. Just trying to figure out what else might be causing it so that i can try and figure it out.

thanks for the help
fatballer189 is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 02-22-2010, 08:47 PM #2
xluben
Ben Johnson Photography
 
xluben's Avatar
 
Join Date: Mar 2007
Location: Minneapolis, MN
Annual Supporting Member
xluben is a Paintball photographer
xluben plays in the PSP
xluben owns a Planet Eclipse Geo
xluben posts videos on PbNation
xluben owns a Planet Eclipse GSL
It is supposed to vent when it fires. That is what allows the bolt to travel forward.
xluben is offline   Reply With Quote
Old 02-22-2010, 08:50 PM #3
fatballer189
 
 
fatballer189's Avatar
 
Join Date: Sep 2007
It is not firing. Air it up and it vents. There is something that is not sealing.
fatballer189 is offline   Reply With Quote
Old 02-22-2010, 09:06 PM #4
xluben
Ben Johnson Photography
 
xluben's Avatar
 
Join Date: Mar 2007
Location: Minneapolis, MN
Annual Supporting Member
xluben is a Paintball photographer
xluben plays in the PSP
xluben owns a Planet Eclipse Geo
xluben posts videos on PbNation
xluben owns a Planet Eclipse GSL
You mean it is a constant leak? That is different than venting.

You'll have to pinpoint the leak if you want any help at all over the internet...
xluben is offline   Reply With Quote
Old 02-22-2010, 09:14 PM #5
fatballer189
 
 
fatballer189's Avatar
 
Join Date: Sep 2007
Quote:
Originally Posted by xluben View Post
You mean it is a constant leak? That is different than venting.

You'll have to pinpoint the leak if you want any help at all over the internet...
Ok ill take a closer look at it tonight and post up tomorrow. I just tried to air it up and there is a constant leak from the noid area. I just trying to find out what could be causing the issue. Im going to check out the spool pack and the gasket and see if there is any messed up o-rings. and get back to you tomorrow
fatballer189 is offline   Reply With Quote
Old 03-03-2010, 12:20 PM #6
C0NTRACTK1LLA
LuLz Patrol
 
C0NTRACTK1LLA's Avatar
 
Join Date: Aug 2007
Location: 719 Springs
C0NTRACTK1LLA supports Team VICIOUS
i had that problem re lube the bolt and every shot you shoot it vents through the grips correct? if so relube your bolt and it should be good to go or check the o rings
__________________
****COMING BACK TO THE GAME - HIT ME UP WITH YOUR GUN PACKAGE OFFERS****
C0NTRACTK1LLA is offline   Reply With Quote
Old 03-03-2010, 01:01 PM #7
coyut
PE Tech and www.341.ch
 
coyut's Avatar
 
Join Date: Jul 2004
Location: Switzerland
 has been a member for 10 years
coyut owns a Planet Eclipse SLS
coyut owns a Planet Eclipse Geo
coyut owns a Planet Eclipse Ego
First of all remove the inlinereg and check the inlinereg piston.
On the bottom, on the end on top of the stem, there needs to be a small black rubber seal. If it is missing or is damaged then the reg will overpressurize the geo, forcing the gasket out of position. This safety feature reduces the chance of damaging the solenoid because of overpressurising.
If this is the case you want to contact your nearest service center to get a new inlinereg piston. Replace the piston and reposition the solenoid gasket.

If the reg is fine and the gasket is in position it most likely will be a problem with one of the spool pack o-rings. If this is the case you might be able to see the damaged o-ring in the slotted air escape path in the manifold. In this case you want to contact your nearest eclipse service center and talk to them on how to get it fixed.

http://www.planeteclipse.com/site/eD...p?show=servcen
__________________
*** Proud member of the "Guild of Eclipse" Tech-Forces ***
Swiss Planeteclipse Service Center

Selling my Coyut SL74

Last edited by coyut : 03-03-2010 at 01:04 PM.
coyut is offline   Reply With Quote
Old 03-04-2010, 08:56 AM #8
Team Capital Offense
 
 
Join Date: Mar 2006
Team Capital Offense owns a Planet Eclipse Geo
Quote:
Originally Posted by C0NTRACTK1LLA View Post
i had that problem re lube the bolt and every shot you shoot it vents through the grips correct? if so relube your bolt and it should be good to go or check the o rings
That is supposed to happen and is completely normal. All GEOs vent when you shoot and it comes ever so slightly through the grip frame.
__________________
Proudly Sponsored By:
ATN Corp., Planet Eclipse, VFORCE, Full Clip USA, Flurry Industries, Tarjac Inc., Command Decisions, Splatbrothers Paintball Facebook: Team Capital Offense
Team Capital Offense is offline   Reply With Quote
Old 03-04-2010, 08:58 AM #9
C0NTRACTK1LLA
LuLz Patrol
 
C0NTRACTK1LLA's Avatar
 
Join Date: Aug 2007
Location: 719 Springs
C0NTRACTK1LLA supports Team VICIOUS
Quote:
Originally Posted by Team Capital Offense View Post
That is supposed to happen and is completely normal. All GEOs vent when you shoot and it comes ever so slightly through the grip frame.
i know but i was talking about when it doesnt shoot as well.. i know its suppose to vent through the grips every time its shot.. thats just what i did when it wasnt firing
__________________
****COMING BACK TO THE GAME - HIT ME UP WITH YOUR GUN PACKAGE OFFERS****
C0NTRACTK1LLA is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump