Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 01-12-2010, 03:18 PM #1
EclipseBaller
radda radda radda
 
EclipseBaller's Avatar
 
Join Date: Sep 2003
Location: So-Mich
 has been a member for 10 years
Board/Eye problem

I'm not new to pbn so I know better to look before I ask but there was nothing listed in the stickies...

Picked up an Ion from my friend to repair it for him. Board turns on great with a fresh battery, light blinks fine. Turn the eyes off and try to dry fire, it shuts off. Same with or without paint or air. Is this an eye board/cable problem or main board problem?
EclipseBaller is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 01-12-2010, 03:46 PM #2
spug
spuggles
 
spug's Avatar
 
Join Date: May 2005
Location: NY
Annual Supporting Member
spug is a Moderator
spug is a Supporting Member
spug is BST Legit
spug donated to help Peyton Trent
spug supports our troops
spug is Legendary
You are just pressing and releasing the button, correct? not holding it?
spug is offline   Reply With Quote
Old 01-12-2010, 04:52 PM #3
EclipseBaller
radda radda radda
 
EclipseBaller's Avatar
 
Join Date: Sep 2003
Location: So-Mich
 has been a member for 10 years
Yes sir. I've worked on Ions before but never had this problem.
EclipseBaller is offline   Reply With Quote
Old 01-12-2010, 05:07 PM #4
DaEagleEye8
Uconn Husky
 
DaEagleEye8's Avatar
 
Join Date: Apr 2006
Location: Storrs, CT
DaEagleEye8 helped look for balloons
DaEagleEye8 owns a Planet Eclipse Ego
DaEagleEye8 owns a Planet Eclipse Ego
DaEagleEye8 is an NCPA player
you using a brand name battery? Ions are really picky with that. Try getting another brand name battery from another pack and see if it solves the problem. Sometimes it has enough power to turn the gun on, but once you shoot, it shuts off.
__________________
-2010-2011 UConn Paintball President
Matt's Outback Paintball
Planet Eclipse
DaEagleEye8 is offline   Reply With Quote
Old 01-12-2010, 05:11 PM #5
EclipseBaller
radda radda radda
 
EclipseBaller's Avatar
 
Join Date: Sep 2003
Location: So-Mich
 has been a member for 10 years
Yeah, it's an industrial energizer. It still stays on, with eyes on, and pulling the trigger, but once something is in the eyes and trigger pulled, it's off.
EclipseBaller is offline   Reply With Quote
Old 01-12-2010, 05:40 PM #6
spug
spuggles
 
spug's Avatar
 
Join Date: May 2005
Location: NY
Annual Supporting Member
spug is a Moderator
spug is a Supporting Member
spug is BST Legit
spug donated to help Peyton Trent
spug supports our troops
spug is Legendary
Try it with the board out of the frame. It's possible that the button sticks, or something causes it to stay in for an extended period of time.
spug is offline   Reply With Quote
Old 01-12-2010, 07:07 PM #7
DaEagleEye8
Uconn Husky
 
DaEagleEye8's Avatar
 
Join Date: Apr 2006
Location: Storrs, CT
DaEagleEye8 helped look for balloons
DaEagleEye8 owns a Planet Eclipse Ego
DaEagleEye8 owns a Planet Eclipse Ego
DaEagleEye8 is an NCPA player
and make sure the connections to the battery itself are all good.
__________________
-2010-2011 UConn Paintball President
Matt's Outback Paintball
Planet Eclipse
DaEagleEye8 is offline   Reply With Quote
Old 01-12-2010, 07:43 PM #8
EclipseBaller
radda radda radda
 
EclipseBaller's Avatar
 
Join Date: Sep 2003
Location: So-Mich
 has been a member for 10 years
Connections are fine and i've tried it with the board AND eyes out and still having the problem. If I had a good set of eyes and cable I could tell right away. Where can I get them for cheap? or will SP replace it?
EclipseBaller is offline   Reply With Quote
Old 01-12-2010, 07:59 PM #9
spug
spuggles
 
spug's Avatar
 
Join Date: May 2005
Location: NY
Annual Supporting Member
spug is a Moderator
spug is a Supporting Member
spug is BST Legit
spug donated to help Peyton Trent
spug supports our troops
spug is Legendary
www.smartpartsparts.com should have everything, but www.punisherspaintball.com might be cheaper.
spug is offline   Reply With Quote
Old 01-12-2010, 09:17 PM #10
EclipseBaller
radda radda radda
 
EclipseBaller's Avatar
 
Join Date: Sep 2003
Location: So-Mich
 has been a member for 10 years
Picking up some new laser eyes on here. Have we diagnosed that that is the problem? They're worth the money either way but I'm convinced that's it.
EclipseBaller is offline   Reply With Quote
Old 01-19-2010, 01:36 PM #11
cowboy_dan
 
 
cowboy_dan's Avatar
 
Join Date: Nov 2009
Location: Racine, wi
I highly doubt the eyes are the problem. If they were the problem, it would show up as the gun shutting off immediately when the beam is blocked (or unblocked), even without pulling the trigger.

Does the gun shut off with the eyes on, nothing in the chamber (no ball), and the trigger pulled? If yes, then something is wrong with the switch (very doubtful), the board, or the wiring between the switch and the board.

Since it sounds like the gun only shuts off when it activates the solenoid, I'd start checking for a short in the wiring to the solenoid. Maybe even some dirt stuck to the backside of the board is shorting it out.
__________________
Stingray II!
V/L Prodigy E-Grip
Ion XE

RIP Combat Cave
cowboy_dan is offline   Reply With Quote
Old 01-26-2010, 01:51 AM #12
EclipseBaller
radda radda radda
 
EclipseBaller's Avatar
 
Join Date: Sep 2003
Location: So-Mich
 has been a member for 10 years
Brand new eyes didn't fix it. Once something is in the eyes it completely shuts off. I see no damage or debris on the board or any jumped connections. The ONLY mark is on the capacitor, it's very very minute, about an 1/8 of an inch scratch which I highly doubt would cause a problem.. would it? Any other solutions?
EclipseBaller is offline   Reply With Quote
Old 01-26-2010, 02:44 PM #13
cowboy_dan
 
 
cowboy_dan's Avatar
 
Join Date: Nov 2009
Location: Racine, wi
Sounds like it needs a new board.
Looking at the Ion schematic, , there isn't much that can be making this happen.
From the schematic, the signal wire to the main board is high (~5v) only when there is something blocking the eyes. But, that 5v is through a 24.5k ohm resistor, so max current if that signal wire was shorted to ground is 0.2mA (0.0002 amps), not near enough to cause this problem.

So you're down to either the chip thinks the power button is being pressed (possibly when something jostles the gun), or something is shorting out the 5v supply and sending the voltage regulator into thermal shudown (which looks like battery removed and re-installed to the chip).
__________________
Stingray II!
V/L Prodigy E-Grip
Ion XE

RIP Combat Cave

Last edited by cowboy_dan : 01-26-2010 at 02:53 PM.
cowboy_dan is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump