Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 06-02-2009, 10:50 PM #1
frenchguyfry
 
 
Join Date: Jun 2009
Arrow Diablo Mongoose Problem? Help!

Hey guys i was hoping you could help me with this. I have a Diablo Mongoose Reincarnation with the LED screen. My problem is it will not fire. I put in a new battery and just took the whole thing apart to make sure it is put together correctly. The screen turns on and the counter says I'm firing but it isn't. I have tried multiple CO2 tanks and everything you can think of. The one thing I think im doing wrong is wen i pit the part under the bolt back in i couldn't figure out how to release the sear so i have been pushing it down manually with an allen wrench. I think this may be my problem so how am i supposed to put that portion in correctly? When i finish assembling the marker it is already cocked which must also be wrong since i can't "un-cock" it.
Thank you for all the help! I really would like it fixed by Friday for the "Giant Big Game" in Hudson Wisconsin!

Ryan
frenchguyfry is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 06-03-2009, 05:03 AM #2
jgilk1
read my sig
 
jgilk1's Avatar
 
Join Date: May 2008
Location: spocompton
i don't know much about the mongoose but general practice dictated if it is an electro with an electronic sear...correct
(stbb electro frame like a spyder)

so is the sear dropping to release the hammer?

did you install the hammer spring in front of or behind the hammer (should go behind)

you are using a 9.6 volt battery correct and not a standard 9 volt!

with spyders that .6 volt can and will be enough not to drop the sear

Last edited by jgilk1 : 06-03-2009 at 05:10 AM.
jgilk1 is offline   Reply With Quote
Old 06-03-2009, 11:40 PM #3
dwrath868
 
 
dwrath868's Avatar
 
Join Date: Feb 2008
Location: Illinois
i also dont know much about the mongoose but i know that if you cant un cock it then you didnt put it back together correctly. try looking in the manule to see if there is anything about it in troubleshooting. if not lok it up online to see if there is something there to help you.
dwrath868 is offline   Reply With Quote
Old 06-04-2009, 03:43 PM #4
frenchguyfry
 
 
Join Date: Jun 2009
I figured it out now, sorry guys, i feel stupid. I figured out you have to turn the eyes off or have something in there(forgot i had eyes on the gun) and my co2 pressure was too low but i tested it at a friends and its working now!
I was also wondering if anyone knows where i could get sticky grips that have a clear plastic part for the screen? Also possibly a better spring kit?
Thanks,
Ryan
frenchguyfry is offline   Reply With Quote
Old 12-19-2009, 11:00 PM #5
weeman72492
 
 
weeman72492's Avatar
 
Join Date: Mar 2009
weeman72492 owns a Planet Eclipse Geo
weeman72492 owns a Planet Eclipse Etek
weeman72492 supports Team VICIOUS
go to www.discountpaintball.com they have dye sticky grips make sure u get them for the spyder even though u have a mongoose they still will fit onto ur gun they run very cheap
weeman72492 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump