Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 09-07-2009, 11:23 AM #1
equis.zero
 
 
Join Date: Feb 2008
Location: Canada
equis.zero supports Empire
DM7 leak issue, yes I checked the stickies first

Hey guys, I have a really stubborn leak in my DM7, I've checked all the stickies and so far nothing has worked.

It's leaking out of the solenoid vent hole, I have changed the orings on the on/off, bolt, and LPR, I've changed the LPR seat, I've lubed the gasket on the solenoid, I've tried replacing the solenoid, I've tried turning down the LPR to see if it was over-pressurized, and still it persists.

Any help would be greatly appreciated. Thanks.
equis.zero is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 09-07-2009, 07:08 PM #2
DeViLs_SouL
 
 
DeViLs_SouL's Avatar
 
Join Date: Aug 2004
Location: Bta
 has been a member for 10 years
Check the middle outer oring in the cylinder
DeViLs_SouL is offline   Reply With Quote
Old 09-07-2009, 07:38 PM #3
Jams419
AKA - Jackal
 
Jams419's Avatar
 
Join Date: Mar 2006
Location: CT but 518 at heart
Jams419 owns a Planet Eclipse SLS
Jams419 has achieved Level 1 in PbNation Pursuit
Jams419 has perfected Level 1 in PbNation Pursuit
have you pulled the plug out? it may need to be resealed with locktite.
__________________
518th Brigade
Jams419 is offline   Reply With Quote
Old 09-07-2009, 11:43 PM #4
brandoo (Banned)
 
Join Date: Nov 2007
Location: Boise, Idaho.
First things first, check the bolt sail.
brandoo is offline   Reply With Quote
Old 09-07-2009, 11:48 PM #5
aapter
DoYouKnowWhatIAmSaying?
 
aapter's Avatar
 
Join Date: Apr 2008
Location: Boise, ID
aapter donated to help Peyton Trent
aapter supports Bob Gurnsey
aapter supports our troops
Quote:
Originally Posted by Jams419 View Post
have you pulled the plug out? it may need to be resealed with locktite.
this. teflon tape will also work
aapter is offline   Reply With Quote
Old 09-08-2009, 03:28 AM #6
Muzz_111
 
 
Muzz_111's Avatar
 
Join Date: Aug 2007
Location: New Zealand
Dude i had this same problem with mine a wee while back tried everything and as a last measure i Replaced the Seal Retainer in the LPR and what do you know problem sloved

Try that and see how you get on if you have already tried changing out all the Orings etc.
__________________
010 Mac Dev Clone - White Dust
09 DM9 - Custom Annoed/Lasered White and Black - Yakuza Powered
09 Ego 9 - Light Trooper
Muzz_111 is offline   Reply With Quote
Old 09-09-2009, 12:12 PM #7
georgeboumrad (Banned)
 
georgeboumrad's Avatar
 
Join Date: Feb 2009
Location: Lutz, fl
also change the oring on the high pressure regs piston.
georgeboumrad is offline   Reply With Quote
Old 09-09-2009, 01:50 PM #8
brentsoffey
Wear Sunscreen
 
brentsoffey's Avatar
 
Join Date: Nov 2004
Location: Portland, OR
brentsoffey supports Cereal Killerz 2
brentsoffey donated to help Peyton Trent
brentsoffey supports Bob Gurnsey
brentsoffey plays in the APPA D5 division
Quote:
Originally Posted by Jams419 View Post
have you pulled the plug out? it may need to be resealed with locktite.
thirding this. if it's leaking out that hole in the back, just degas it, take out the plug, teflon tape it, screw it back in. problem solved.
__________________
Feedback: +9 Old / +8 New

Music is the only sensual pleasure without vice.
brentsoffey is offline   Reply With Quote
Old 09-09-2009, 02:32 PM #9
equis.zero
 
 
Join Date: Feb 2008
Location: Canada
equis.zero supports Empire
To everyone mentioning the plug: it's not that hole, it's leaking from the tiny hole right behind the solenoid.

I have replaced the bolt sail oring several times with no success.

I also tried replacing the seat retainer in the LPR, no luck with that.

I'll take a look at the HPR piston oring.

Thanks everyone for your suggestions.
equis.zero is offline   Reply With Quote
Old 09-09-2009, 10:16 PM #10
kilmo
 
 
kilmo's Avatar
 
Join Date: Aug 2009
Quote:
Originally Posted by equis.zero View Post
To everyone mentioning the plug: it's not that hole, it's leaking from the tiny hole right behind the solenoid.

I have replaced the bolt sail oring several times with no success.

I also tried replacing the seat retainer in the LPR, no luck with that.

I'll take a look at the HPR piston oring.

Thanks everyone for your suggestions.
I don't know if this will help at all...but I had a similar problem with my DM6....I had a leak near the solenoid between the noid and the on/off plug....I took it out, swapped out all the rings, lubed it up and put it back in....then I blue loctited the screw that holds it in place, and screwed it in hard so it in effect becomes a continuous flow plug.....it seemed to stop the leak....

Before I did this, my DM wouldn't even cycle, now it's cycling again....give that a whirl and see if that helps.....that is, if the leak is in the same place.

Cheers,
Kilmo
kilmo is offline   Reply With Quote
Old 09-13-2009, 01:20 AM #11
georgeboumrad (Banned)
 
georgeboumrad's Avatar
 
Join Date: Feb 2009
Location: Lutz, fl
hey, i just got my dm7 and it was all good until i adjusted the lpr and stuff, now it leaks from somewhere arond the solenoid. when i gas it up it leaks a good amount but after a couple shots the leak gets smaller but i still want to fix it. i think its the solenoid screws just need to be loctited
georgeboumrad is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump