Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

View Poll Results: good brand new?
shot nice out of box? 18 85.71%
problems that needed it to be sent to dye 3 14.29%
Voters: 21. You may not vote on this poll

Reply
 
Thread Tools
Old 11-09-2008, 01:09 AM #1
ToXic PaiNtBall1109
 
 
ToXic PaiNtBall1109's Avatar
 
Join Date: Jan 2007
Location: so cal
working out of the box

personaly my 08 slg worked perfectly fine out the box with me no problems at all

Last edited by ToXic PaiNtBall1109 : 11-09-2008 at 02:24 PM.
ToXic PaiNtBall1109 is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 11-09-2008, 02:33 AM #2
PaInTbAlLeR91
Witty User Title
 
PaInTbAlLeR91's Avatar
 
Join Date: Apr 2004
Location: So Cal/562
 has been a member for 10 years
Had to send my first one in.
When it came back, shot amazing with free goodies to boot.(On/Off)
PaInTbAlLeR91 is offline   Reply With Quote
Old 11-09-2008, 02:19 PM #3
shadoflame
i can pump 30 bps, no AT.
 
shadoflame's Avatar
 
Join Date: Jan 2006
Location: Houston
shadoflame owns a Planet Eclipse Etek
we're talking about the 09 SLG?
__________________
"Originally posted by loneassassin: The problem is, they keep making better idiots..."
shadoflame is offline   Reply With Quote
Old 11-09-2008, 02:23 PM #4
ToXic PaiNtBall1109
 
 
ToXic PaiNtBall1109's Avatar
 
Join Date: Jan 2007
Location: so cal
Quote:
Originally Posted by shadoflame View Post
we're talking about the 09 SLG?
the 08 ill edit first post
ToXic PaiNtBall1109 is offline   Reply With Quote
Old 11-09-2008, 07:53 PM #5
ToXic PaiNtBall1109
 
 
ToXic PaiNtBall1109's Avatar
 
Join Date: Jan 2007
Location: so cal
woah i thought alot of people had problemes with there slgs
ToXic PaiNtBall1109 is offline   Reply With Quote
Old 11-10-2008, 04:51 AM #6
Tcheno
 
 
Tcheno's Avatar
 
Join Date: May 2006
Location: Portugal
Quote:
Originally Posted by ToXic PaiNtBall1109 View Post
woah i thought alot of people had problemes with there slgs
That's because this forum is designed to help people and usualy those with little to no problems just don't post.
That's also the reason why the SLG forum is getting so quiet these days...
Tcheno is offline   Reply With Quote
Old 11-10-2008, 05:10 AM #7
dpolendo88
 
 
Join Date: Oct 2008
Body defect on my SLG made my gun unusable for the first Five months I had it. I sent it in twice, second time around they decided to replace my gun. I sold it and now I use a DP G3
dpolendo88 is offline   Reply With Quote
Old 11-10-2008, 01:43 PM #8
shadoflame
i can pump 30 bps, no AT.
 
shadoflame's Avatar
 
Join Date: Jan 2006
Location: Houston
shadoflame owns a Planet Eclipse Etek
mine's fine now. i had an out of spec bolt that broke. my team mate had the 08 SLG and had a series of problems with it, 1, short bolt, 2 board, and 3, short bolt was replaced with out of spec bolt, which broke...
__________________
"Originally posted by loneassassin: The problem is, they keep making better idiots..."
shadoflame is offline   Reply With Quote
Old 11-10-2008, 04:11 PM #9
xluben
Ben Johnson Photography
 
xluben's Avatar
 
Join Date: Mar 2007
Location: Minneapolis, MN
Annual Supporting Member
xluben is a Paintball photographer
xluben plays in the PSP
xluben owns a Planet Eclipse Geo
xluben posts videos on PbNation
xluben owns a Planet Eclipse GSL
My 08 SLG had the short bolt problem and had to be sent back right out of the box.
xluben is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump