Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

 
 
Thread Tools
Old 09-17-2008, 01:14 PM #1
leavell119
 
 
leavell119's Avatar
 
Join Date: Mar 2008
anyone still having a problem with the lense?

I got my new lense after theyrecalled the first ones.. it worked fine for a while but this weekend, i noticed it broke again at the mounting point where your "clip" goes in.... Just curious if this is still happening to others or just me..
leavell119 is offline  
Old 09-18-2008, 01:42 PM #2
akara13
South West PB
 
akara13's Avatar
 
Join Date: Jul 2008
Location: Jacksonville NC
akara13 owns a Planet Eclipse Ego
akara13 owns a Planet Eclipse Lv1
akara13 has achieved Level 1 in PbNation Pursuit
I have never had a problem with mine. I did not know they recalled them I will have to find out if I need to replace mine
akara13 is offline  
Old 09-18-2008, 01:53 PM #3
daveJRB
 
 
Join Date: Apr 2008
ya they recalled the dubble pain lenses (they were cut wrong) haven't heard of them braking thow.
__________________
myspace.com/teamjrb
sponsored by:
Save Phace www.savephace.com
daveJRB is offline  
Old 09-19-2008, 10:50 AM #4
akara13
South West PB
 
akara13's Avatar
 
Join Date: Jul 2008
Location: Jacksonville NC
akara13 owns a Planet Eclipse Ego
akara13 owns a Planet Eclipse Lv1
akara13 has achieved Level 1 in PbNation Pursuit
Thanks Dave I do not have a double pane lens only the single, so I do not have to worry about it. I have taken many shots in the lens without any marks yet.
akara13 is offline  
Old 09-19-2008, 02:52 PM #5
leavell119
 
 
leavell119's Avatar
 
Join Date: Mar 2008
yeah well i guess it has to do with the way they cut the hole the lil clip sits in. if its oval, its right, if its horseshoe shaped, its wrong.
leavell119 is offline  
Old 09-22-2008, 09:21 AM #6
The Real Boss
Save Phace CFO
 
Join Date: Apr 2008
Location: Texas
Quote:
Originally Posted by leavell119 View Post
I got my new lense after theyrecalled the first ones.. it worked fine for a while but this weekend, i noticed it broke again at the mounting point where your "clip" goes in.... Just curious if this is still happening to others or just me..
The only recall that was done was on the thermal lens due to the thermal pane being cut to the wrong size which did not allow the lens to fit into the mask at all.

Please send us your lens so that we can investigate what happened. Send it to:

Save Phace
Warranty Department
2717 Fallon Drive
Sherman TX 75090

Please feel free to contact us if we can be of any further assistance. 866-783-3223 ext 3.

Thanks!!
The Real Boss is offline  
Old 09-22-2008, 02:29 PM #7
AmbushSabre
Where the white women at?
 
AmbushSabre's Avatar
 
Join Date: Aug 2008
Location: NH
AmbushSabre helped look for balloons
fine almost does not fit the goggles and the seal of the thermal lens is already broken after 1 day of play
AmbushSabre is offline  
Old 09-23-2008, 10:06 AM #8
leavell119
 
 
leavell119's Avatar
 
Join Date: Mar 2008
Staci has already been in contact with me. Ill be sending the lense back to you guys for further investigation.
leavell119 is offline  
 


Thread Tools

Posting Rules
Forum Jump