Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 03-24-2008, 08:30 AM #1
jemvai
 
 
Join Date: Mar 2008
Power button stays on??

Hopefully somebody can help me.
My EOS's power button stays on (a solid red ) no blinking at all. it won't do anything, any ideas? I have only played with this thing twice and love this marker. You guys think the board is shot?

I have tried a new battery and still no luck?

Also I have a liquid carbon frame # 294 With no flaking. Did all of the early ones have that problem? should I send it in before it starts?

Thanks people.
jemvai is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 03-24-2008, 06:12 PM #2
Sean@smartpartswest
Living Legends May 18-20!
 
Sean@smartpartswest's Avatar
 
Join Date: Jun 2004
Location: Buenos Aires, Argentina
 has been a member for 10 years
Sean@smartpartswest is playing at Living Legends III
Sean@smartpartswest is playing at Living Legends V
Did you adjust the trigger at all?

Make sure you did not take out all the pre-travel meaning the trigger has the micro switch already activated. The light would stay on if you did that.
__________________
Sean Scott
Co-Creator of Living Legends

smart.corps.sean@gmail.com

www.cpxsports.com
www.livinglegendsofpaintball.com
Sean@smartpartswest is offline   Reply With Quote
Old 03-24-2008, 08:22 PM #3
jemvai
 
 
Join Date: Mar 2008
Thanks Sean, but unfortunately,I never adjusted the trigger it still has the stock setup. any other ideas?

Thanks
jemvai is offline   Reply With Quote
Old 03-25-2008, 09:39 AM #4
Sean@smartpartswest
Living Legends May 18-20!
 
Sean@smartpartswest's Avatar
 
Join Date: Jun 2004
Location: Buenos Aires, Argentina
 has been a member for 10 years
Sean@smartpartswest is playing at Living Legends III
Sean@smartpartswest is playing at Living Legends V
Ok, next thing. Pop of the clear on off button out of the frame. Using an allen wrench, manually hit the on/off button on the boar with an allen wrench lightly. If it turns on and of normally, then the clear button is the problem. If it still does the same thing, the button on the board is friend and you need to send it back in.
__________________
Sean Scott
Co-Creator of Living Legends

smart.corps.sean@gmail.com

www.cpxsports.com
www.livinglegendsofpaintball.com
Sean@smartpartswest is offline   Reply With Quote
Old 03-26-2008, 07:12 AM #5
jemvai
 
 
Join Date: Mar 2008
Thanks Sean, That looks like the culprit. I am bringing it back to the place I got it, They have an authorized sp tech and said they would fix it within a 24hr turnaround under warranty. Woo hoo!

Thanks for your help.
jemvai is offline   Reply With Quote
Old 03-26-2008, 10:01 AM #6
Sean@smartpartswest
Living Legends May 18-20!
 
Sean@smartpartswest's Avatar
 
Join Date: Jun 2004
Location: Buenos Aires, Argentina
 has been a member for 10 years
Sean@smartpartswest is playing at Living Legends III
Sean@smartpartswest is playing at Living Legends V
Awesome!
__________________
Sean Scott
Co-Creator of Living Legends

smart.corps.sean@gmail.com

www.cpxsports.com
www.livinglegendsofpaintball.com
Sean@smartpartswest is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump