Need help quick!? Post here. - PbNation
Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

 
Archived Thread - Cannot Edit  
Old 02-08-2007, 06:44 PM #1
paintball_kidz
.
 
paintball_kidz's Avatar
 
Join Date: Jun 2004
Location: Vancouver, BC Canada
 has been a member for 10 years
Need help quick!? Post here.

I know alot about the defiant 2, (a former owner & guru) I know it from the inside out. Experienced almost all problems that arised with the defiant.

I'm on the computer for the majority of the day and will be able to get a reply quickly.
Yes you can say I have no life


So yeah, Post here if you need a quick hand. I can help you trouble shoot.
Will help you to the best of my ability.
__________________
I used to play paintball

Last edited by paintball_kidz : 02-08-2007 at 07:05 PM.
paintball_kidz is offline  
Old Sponsored Links Remove Advertisement
Advertisement
Old 02-08-2007, 07:06 PM #2
b_ron
photo
 
b_ron's Avatar
 
Join Date: Nov 2005
Location: [sOCal]
b_ron helped look for balloons
b_ron owns a Planet Eclipse Ego
b_ron is an NCPA player
b_ron plays in the APPA beginner division
all hail the defiant guru!


got a quick lil question. do you have to lube the ram sleeve o-rings? or just the ram housing o-ring
__________________

| photo |



RIP ABC. It's been a fun 17 threads.
b_ron is offline  
Old 02-08-2007, 07:16 PM #3
paintball_kidz
.
 
paintball_kidz's Avatar
 
Join Date: Jun 2004
Location: Vancouver, BC Canada
 has been a member for 10 years
Take a q-tip and rub it in there, or just use your pinky finger and rub it in there.
__________________
I used to play paintball
paintball_kidz is offline  
Old 02-12-2007, 07:49 PM #4
K-Saw
Hate Train
 
K-Saw's Avatar
 
Join Date: Dec 2006
Location: Bonesaw, GA
I don't know what has happened to my board... I'd turn it on and the led would just stay red for a while then turn off, then it would be dim red and turn off, and then not even turn red. I tried multiple batteries and still no luck. Any clue?
K-Saw is offline  
Old 02-12-2007, 10:58 PM #5
paintball_kidz
.
 
paintball_kidz's Avatar
 
Join Date: Jun 2004
Location: Vancouver, BC Canada
 has been a member for 10 years
lets start from, Make sure all you wires are TIGHT.

Some what you describe it does sound like the battery is dead. But you stated that you replaced with multiples of batterys.
__________________
I used to play paintball
paintball_kidz is offline  
Old 02-12-2007, 11:21 PM #6
K-Saw
Hate Train
 
K-Saw's Avatar
 
Join Date: Dec 2006
Location: Bonesaw, GA
I just double checked all the wires and they're all tight so I have no clue what it could be unless the board got fried somehow...
K-Saw is offline  
Old 02-13-2007, 06:51 AM #7
pb_matt_90
 
 
pb_matt_90's Avatar
 
Join Date: May 2005
Location: That Panhandle, FL
ok lets give this a try then...

So when I air up my D2 the bolt does not air up with the rest of the gun? I have tried zeroing out the regs and bringing them into about 90 and it worked for about 15 sec and then all of a sudden it started leaking pretty bad from the inside.

Any help would be great o' great one
pb_matt_90 is offline  
Old 02-13-2007, 03:16 PM #8
the-
Stop Lubricating.
 
the-'s Avatar
 
Join Date: Oct 2006
pb matt try ur battery

paintball kidz u still got ur ram guage thing to test pressure of the lpr? if so ill do 10 bucks shipped if your trying to get rid of parts...

edit//detaching the main wire harness from noid to battery..just pull hard??

ninja edit//fixed nvm

Last edited by the- : 02-13-2007 at 03:30 PM.
the- is offline  
Old 02-13-2007, 06:00 PM #9
paintball_kidz
.
 
paintball_kidz's Avatar
 
Join Date: Jun 2004
Location: Vancouver, BC Canada
 has been a member for 10 years
Quote:
Originally Posted by pb_matt_90 View Post
ok lets give this a try then...

So when I air up my D2 the bolt does not air up with the rest of the gun? I have tried zeroing out the regs and bringing them into about 90 and it worked for about 15 sec and then all of a sudden it started leaking pretty bad from the inside.

Any help would be great o' great one

Check your hoses that connect to your barbs, It could have blown off because of the pressure. Please check your LPR pressure also.

A reminder of how important that guage is...

Ps:
-the : nope sorry I sold it along with my gun. Call BLAST maybe they'll send you one for free.
__________________
I used to play paintball
paintball_kidz is offline  
Old 03-13-2007, 01:00 PM #10
soadrules
RAGE FTW
 
soadrules's Avatar
 
Join Date: Feb 2006
Location: SOFLA *954*
ok guru.. here is my problem. I have bolt stick after consecutive shots. and releases air as if i was out of air. but the tanks is always or 1k. all the orings have been lubed and checked. on the hpr, lpr, and ram sleeve. help me o great one
__________________
DON'T GET ELIMINATED!!!! (MXC)
MIAMI RAGE LOCAL SQUAD
MIAMI RAGE FAN #85 FTW
Russian Legion Fan #787
http://www.pbnation.com/showthread.php?t=2231303
DEfiant 2 F/S/T
http://www.pbnation.com/showthread.p...2#post32693532
feedback ^ ^ ^ ^ ^
soadrules is offline  
Old 03-13-2007, 02:19 PM #11
Alien Star
The Invasion is Coming!
 
Alien Star's Avatar
 
Join Date: Mar 2007
Location: Mars
What is bolt stick?
Alien Star is offline  
Old 03-18-2007, 06:38 PM #12
flyingswan032
 
 
flyingswan032's Avatar
 
Join Date: Mar 2007
i got a cp reg and i need to get a rebuid kit for it and im not sure which 1 to get
flyingswan032 is offline  
Old 03-18-2007, 07:24 PM #13
nublet_slayer
 
 
nublet_slayer's Avatar
 
Join Date: Feb 2007
Location: 570
nublet_slayer owns a Planet Eclipse Ego
nublet_slayer owns a Planet Eclipse Ego
nublet_slayer supports Team VICIOUS
i have a question, what upgrade bolt would work with the defiant 2?
nublet_slayer is offline  
Old 03-18-2007, 08:23 PM #14
flyingswan032
 
 
flyingswan032's Avatar
 
Join Date: Mar 2007
im gettin a cp reg adapter but i need to get a rebuild kit for my cp reg. At the customproducts.com there are High ver. 1,2, and Low ver. 1,2. im not sure which one to get???

anyhelp.
flyingswan032 is offline  
Old 03-19-2007, 04:34 PM #15
dnick453
Robotic KHAT
 
dnick453's Avatar
 
Join Date: Jul 2006
Location: Valparaiso, IN
Heh, I'm a guru too you know

Don't I get a warm welcome guys... it's been about 6 months since I've been on PbN. The warm weather forced me to use my marker a bit so I thought I'd pop by.

To nublet slayer - currently the only bolts that work with the defiant are the stock ones that you can modify, Acid Custom's bolt, and the inverted pb bol sold by our own incubus. My answer has about 6 months worth of rust on it... so who knows, maybe some private label has realeased on since then... enlighten me

On to flyingswan. The high and low versions refer to what pressure setup you are using. Are you using an LP or HP tank? That's the deciding factor in which rebuild kit your need. Also, before you go spending your cash on a rebuild kit, are you 100% sure that you need a rebuild kit and maybe just not an o-ring + lube here and there? Also, I don't know, but how much are rebuild kits, you may be able to get a nicer reg for a little more. Maybe not, again I don't know the price of the rebuild kit, just thought I'd suggest it as I'm not a huge fan of CP's. Call it Race-CP-ism but... I just don't think they perform that well and are overrated some. Good luck all, I'll keep stopping by to help you guys. And I think I may make a video tutorial on some performance increasing mods coming up soon.
__________________
I tech and fix your Defiants
Official "Loc-tite Tastes Good Club" Member #1 and founder
http://i94.photobucket.com/albums/l8...k454/dodgy.gif
dnick453 is offline  
Old 03-19-2007, 10:00 PM #16
Babycakes
 
 
Babycakes's Avatar
 
Join Date: Aug 2006
Location: Central, LA
Hey guys. Im new to the defiant family cuz I downgraded from a timmy. My defiant has a SERIOUS leak coming from about the middle of the gun. The ram looks good and is lubed up. My friend who used to have one said that he thinks that the valve may be dented or something. I played with it all day saturday without one problem. But when I gased it up to shoot some paint to show my other friend how good it is, the bolt cycled back and then sucked forward with a massive leak coming from the area in front of the ram.

I tried to take the valve out to take a look at it but couldnt get the bugger out for the life of me. I know that the set screw at the bottom has to be removed but aside fromt that I am clueless on how to get it out. In case I have to take it to the proshop, about how much will a new valve be. Or do you think that its the valve at all.
__________________
Back to Rockin The Dark Shocker


PM7
http://www.pbnation.com/showthread.php?t=2338579

Black Dark Shocker
http://www.pbnation.com/showthread.php?t=2351287
Babycakes is offline  
Old 03-20-2007, 04:42 PM #17
dnick453
Robotic KHAT
 
dnick453's Avatar
 
Join Date: Jul 2006
Location: Valparaiso, IN
I posted in your thread about the leak...take a look there and tell me a little more about it.
__________________
I tech and fix your Defiants
Official "Loc-tite Tastes Good Club" Member #1 and founder
http://i94.photobucket.com/albums/l8...k454/dodgy.gif
dnick453 is offline  
 




Posting Rules
Forum Jump